Welcome

Welcome to SpectraPLUS-DT

SpectraPLUS-DT is a powerful multi channel spectrum analyzer. The program interfaces with the Data Translation DT-9800 series of data acquisition modules to provide Real-Time spectral analysis as well as Recording , and Post-Processing capabilities; it gives you the ability to make frequency response, distortion, and transfer function measurements. It supports a wide range of FFT sizes, smoothing windows , digital filtering , overlap processing , averaging , peak hold , triggering , narrowband or octave (1/1, 1/3, etc) scaling and can display, export and print the Time Series , Spectrum , Phase , 3-D Surface plot, and Spectrogram . A Signal Generator utility produces pink/white noise, swept sine, tones, and pulses. Although all signal processing is performed on the CPU, real-time performance is possible with today's machines.

See Also: Licensing , Basic Operation , What is a Spectrum Analyzer


What is a Spectrum Analyzer

A spectrum analyzer is an instrument used to convert a signal from the time domain (amplitude-vs-time) to the frequency domain (amplitude-vs-frequency). If you are familiar with an ordinary oscilloscope you know what a time domain display looks like. A frequency domain display is known as a spectrum. Unless you are measuring a single tone, an oscilloscope provides little in the way of frequency information; however, a spectrum analyzer clearly reveals this information.

What Can it Do?

A Spectrum Analyzer is very useful for measuring the fundamental frequency components which are contained in a signal. It can accurately measure the frequency of single or multiple tones and the frequency difference between them.

How does it work?

The program works in conjunction with a DT 9800 data acquisition module. SpectraPLUS -DT then performs an "Analog-to-Digital" conversion on the analog signal. This digitized signal is then passed through a math algorithm known as a Fast Fourier Transform (FFT) which converts the signal from the time domain to the frequency domain. The CPU on your computer is used to perform this transformation.

See also: Performance Issues


System Requirements

Current Minimum System Requirements:

1.0 GHz CPU recommended minimum

1 GB RAM minimum, 40 MB hard disk space

Data Translation DT-9800 data acquisition module (not required for post processing)


Basic Operations

The program acquires data from a Data Translation DT-9800 multichannel industrial data acquisition USB hardware module and performs FFT based signal processing operations and displays the results.

The program has three distinct operating Modes and five separate Plots.

Modes

  • Real-Time mode takes the signal directly off of the DT-9800 module, processes it and displays the results. You can run for an indefinite period of time but the last 60 seconds (user adjustable) will be buffered. If you stop the analyzer and change to the Recorder or Post Processing mode you will be given a chance to save this data buffer to a wave file.
  • Recorder mode allows you to save the raw digitized signal to your hard disk in the form of a .WAV file. You can also playback the signal through the DT-9800 D/A channel or through your sound card output channel. To begin playback you must first select the time segment to play by clicking the selection arrow on the time series polot and then clicking and dragging across the data segment. Pressing the "Play" button (speaker icon on the plot toolbar) will begin playback. Only one channel can be played back at a time.
  • Post-Processing mode allows you to process data which was previously recorded and stored on disk in a .WAV file. This mode allows greater flexibility than the Recorder or Real-Time modes in the analysis process. In particular, this mode allows the use of overlap processing to effectively stretch the time resolution in both the Spectrogram and 3-D Surface plots.

Plots

  • The Time Series plot shows the digitized waveform. It is similar to an oscilloscope display (amplitude versus time).
  • The Spectrum plot displays the amplitude of the signal versus frequency.
  • The Phase plot displays the phase of the signal versus frequency.
  • The Spectrogram plot displays the spectra over time. The amplitude is shown in color or grayscale.
  • The 3-D Surface plot displays a perspective of the spectra over time.

See also: Setting up the Analyzer


Setting up the Analyzer

Getting Started - Setting up the Analyzer

Setup the Hardware:

Install the DT-9800 hardware and drivers (refer to instructions included with your hardware) and connect the transducer you wish to measure to the input channels.

Configure the Device:

Prior to making a measurement, you need to configure the hardware. Click the <Options><Processing Settings> menu, press the F4 key, or click the I/O toolbar button to open the Input Device settings. Select the DT-9800 device to use, set the Sampling Rate to at least twice the highest frequency you need to measure and enable one or more input channels.

Frequency Range:

Go to the FFT Settings dialog box by selecting the <Options><Processing Settings> menu item or the F4 key, and click on the FFT Settings tab Set the Sampling Rate to at least twice the highest rate that you wish to measure. Now adjust the FFT size as needed.

Axis Scaling:

Go to the Scaling dialog box by selecting the Scaling tab under the <Options><Processing Settings> menu item. Select the appropriate scaling options. The program defaults to Logarithmic amplitude scaling and Logarithmic frequency axis scaling.

Open the Plots:

Click the <Plots><Select Single Channel Plots> menu to select the plots. Pressing F5 or pressing the corresponding toolbar button will also open the plot selection dialog. Plots can be opened and closed even when the processor is running but in the case of the 3-D Surface and Spectrogram plots, the contents are erased once closed.

Select the Operating Mode:

Select the Recorder mode if you wish to save the waveform data for later processing. Select Real-Time mode if you wish to run in a monitor mode without saving the data. The Real-Time mode will allow you to run continuously whereas the Recorder mode is limited by available hard disk space or memory (depending on the selected File Options) on the computer. Post Processing mode is used for processing from a previously recorded WAV file. Click the <File><Open> menu to process one or more existing wave files.

Start the Analyzer:

Click <Run> or <Rec> on the toolbar or use the associated accelerator key <alt> <R> to start the processor. The displays will then begin updating.

Stop the analyzer and make a measurement

Click <Stop> on the toolbar or use the associated accelerator keys <alt> <S> to stop the processor. Use the mouse to point to a feature of interest on one of the plots and press the left mouse button. Measurement boxes will appear which contain the corresponding plot values. (See Cursor Measurements for more information). Right clicking on the plot will popup a menu with many useful operations; you can also copy the contents to the Windows clipboard from this menu.

Print the results

Selecting the <File> <Print> menu item will print the active plot on the selected printer. You will also have an opportunity to enter custom annotation which is printed along the top center of the page.

Save the configuration

You may save the current analyzer configuration at any time by using the <File> <Load> Configuration menu item. All current settings are saved as well as the size and position of each plot and any open WAV file.

See also: Basic Operation, What is a Spectrum Analyzer? , Opening and Saving Wave files , Aliasing, Printing , Configuration Files , Keyboard Shortcuts


Cursor Measurements

Left Mouse Button:

Pressing the left mouse button anywhere within the plot region will display horizontal and vertical measurement boxes containing the values of the X and Y positions pointed to.

Control Key + Left Mouse button:

Holding down the Control Key and clicking the left mouse button anywhere within the plot region and dragging will display horizontal and vertical measurement boxes containing the differential values of the X and Y positions relative to the starting point. This is very useful for measuring the difference between two points on the plot.

Shift Key + Left Mouse button:

Holding down the Shift Key and clicking the left mouse button anywhere within the plot region will display a set of "harmonic cursors". These cursors show the first 10 harmonic frequencies. This is very useful for identifying harmonically related components within a complex spectrum.

Control + Shift Key + Left Mouse button:

Holding down both the Control and Shift Keys and clicking the left mouse button anywhere within the plot region will display a set of "sideband cursors". These cursors show additional measurement lines on both the upper and lower sides of the start point. This is very useful for identifying modulation related components within a complex spectrum.

Right Mouse Button:

Pressing and holding the right mouse button within any plot will activate a popup menu containing additional editing and processing options. The contents of this popup menu depends upon the specific plot. See the Right Click Action Menu topic for more information.

The Spectrum and Phase plots will "pull" the cursor to the trace along the amplitude axis. This can be disabled from the spectrum/phase display options dialog box.

Notes:

  • It is recommended that you "Stop" the Analyzer while using these mouse actions. There are no corresponding keyboard commands.
  • The 3-D Surface plot can be deceptive; you must measure along the base (X-axis) of the plot to determine the correct frequency. Aligning with the top of a peak will skew the measurement to the left because of the perspective orientation of the display.

See also: Keyboard Shortcuts, Toolbar


Right Click Action Menus

A single click with the right mouse within the plot area of any plot will activate a menu containing a variety of additional actions. Although some of these actions are familiar clipboard operations, many provide powerful "cross display" functions for post processing and analysis.

Time Series Plot

Select All - selects the displayed time series for editing.

Cut - cuts selected time segment and places it on the clipboard in .WAV format.

Copy As Wave - copies the selected time segment to the clipboard in .WAV format.

Copy As Text - copies the selected time segment to the clipboard in a tab delimited text format.

Copy as Bitmap - copies the plot image to the clipboard in standard bitmap format.

Save To Wave File - saves the selected time segment to a new wave file (you will be prompted to enter a filename)

Write To Bitmap File - writes the plot image to a bitmap file (you will be prompted for the filename and location).

Mute - mutes the selected time segment.

Filter - filters the selected time segment.

Play - plays the selected time segment through current output device .

Autoscale Display - Evaluates the data and sets the Plot Top/Range parameters to optimum values.

Pull Cursor To Trace - If this option is enabled, the measurement cursor will automatically "pull" to the waveform trace along the amplitude axis.

Compute and Display Average Spectrum - computes and displays the average spectrum for the selected time segment using infinite averaging . The spectrum plot is opened if necessary.

Compute and Display Spectrogram - computes and displays the spectrogram for the selected time segment using the current FFT size and averaging settings. An overlap percentage is used so that the entire time segment will fill the spectrogram plot. The spectrogram plot is opened if necessary.

Compute and Display 3-D Surface - computes and displays the 3-D Surface plot for the selected time segment using the current FFT size and averaging settings. An overlap percentage is used so that the entire time segment will fill the 3-D Surface plot. The 3-D Surface plot is opened if necessary.

Compute and Display RT-60 - Opens and Calculates the Reverberation Time for the selectet time segment. Click here for more details

Perform DTMF Analysis - Decodes DTMF key presses (touch tones) for the selected time segment.

Compute RMS, Max, Min, and Peak to Peak Levels - Computes the RMS level, max/min and peak to peak values for the selected time segment.

Convert to RMS values - Converts the selected time segment to RMS values and displays the results. User is prompted to enter the RMS time duration.

Compute Crest Factor - Computes and displays the crest factor for data set.

Compute Envelope Using Hilbert Transform - Computes the Envelope (magnitude) of the selected time segment using the Hilbert Transform. The results are displayed in the time series plot. Click on the "zoom out full" button to return to the normal display mode.

Compute Schroeder Integration - Computes a reverse integration (right to left) based on M. R. Schroeder's method. The results are displayed in the time series plot. Click on the "zoom out full" button to return to the normal display mode.

Compute Cumulative Sound Exposure Level (C-SEL) - produces a plot of the forward integration of the selected time segment. Best displayed using Logarithmic amplitude scaling on the time series plot. This measurement is often used in underwater noise assessment such as pile driving.

Export Peak Values to Text File - creates a text file containing the time, peak and rms levels for all events in the selected time segment. You will be prompted for the threshold and filename.

View Data Values - displays a table containing the current time series values. The contents of this table will update whenever the time series display changes.

Properties - activate the display options dialog box.

Help - activates the online help.

Spectrum Plot

Copy as Text - copies the displayed spectrum values to the clipboard in tab delimited text format.

Write to Text File - writes the displayed spectrum values to an ASCII text file.

Copy as Bitmap - copies the plot image to the clipboard in standard bitmap format.

Write To Bitmap File - writes the plot image to a bitmap file (you will be prompted for the filename and location).

Inverse FFT - performs an Inverse FFT and displays the results in the time series plot .

Compute Cepstrum - performs an FFT on the current spectral data.

Bandwidth and Q Factor - computes and displays the half power bandwidth and Quality Factor for the maximum peak in the display.

Clear Spectrum - clears the current spectrum. This is useful if you wish to plot/print overlays with just the peak hold trace

Clear Peak Hold - clears the current spectrum. This is useful if you wish to plot/print overlays without the peak hold trace.

Autoscale Specctrum - Evaluates the data and sets the Plot Top/Range parameters to optimum values.

Pull Cursor To Trace - If this option is enabled, the measurement cursor will automatically "pull" to the spectrum trace along the amplitude axis.

Set Marker N - activates marker N at the frequency of the mouse click point.

Clear Marker N - clear individual markers

Marker Options - activates the Marker Options dialog box

Smooth Spectrum N - averages N adjacent bins to smooth the spectral data (requires narrowband freq scaling and logarithmic amplitude scaling).

View Data Values - displays a table containing the current spectrum values. The contents of this table will update whenever the display changes.

Properties - activate the display options dialog box.

Help - activates the online help.

Phase Plot

Copy as Text - copies the displayed phase values to the clipboard in tab delimited text format.

Copy as Bitmap - copies the plot image to the clipboard in standard bitmap format.

Write To Bitmap File - writes the plot image to a bitmap file (you will be prompted for the filename and location).

Pull Cursor To Trace - If this option is enabled, the measurement cursor will automatically "pull" to the trace along the phase axis.

View Data Values - displays a table containing the current phase values. The contents of this table will update whenever the display changes.

Properties - activate the display options dialog box.

Help - activates the online help.

3-D Surface Plot

Cut - cuts selected time segment and places it on the clipboard in .WAV format.

Copy as Wave - copies the selected time segment to the clipboard in .WAV format.

Copy as Bitmap - copies the plot image to the clipboard in standard bitmap format.

Write To Bitmap File - writes the plot image to a bitmap file (you will be prompted for the filename and location).

Mute - mutes the selected time segment.

Filter - filters the selected time segment.

Play - plays the selected time segment through current output device .

Autoscale 3-D Surface - Evaluates the data and sets the Plot Top/Range parameters to optimum values.

Display Time Series - displays the time series corresponding to the selected segment. The time series plot is opened if necessary.

Compute and Display Average Spectrum - computes and displays the average spectrum for the selected time segment using infinite averaging . The spectrum plot is opened if necessary.

Compute and Display Spectrogram - computes and displays the spectrogram for the selected time segment using the current FFT size and averaging settings. An overlap percentage is used so that the entire time segment will fill the spectrogram plot. The spectrogram plot is opened if necessary.

Expand 3-D Surface - expands the 3-D Surface plot by recomputing the data for the selected time segment. An overlap percentage is used so that the entire time segment will fill the 3-D Surface plot.

Properties - activate the display options dialog box.

Help - activates the online help.

Spectrogram Plot

Cut - cuts selected time segment and places it on the clipboard in .WAV format.

Copy as Wave - copies the selected time segment to the clipboard in .WAV format.

Copy as Bitmap - copies the plot image to the clipboard in standard bitmap format.

Write To Bitmap File - writes the plot image to a bitmap file (you will be prompted for the filename and location).

Mute - mutes the selected time segment.

Filter - filters the selected time segment.

Play - plays the selected time segment through current output device .

Autoscale Spectrogram - Evaluates the data and sets the Plot Top/Range parameters to optimum values.

Display Time Series - displays the time series corresponding to the selected segment. The time series plot is opened if necessary.

Compute and Display Average Spectrum - computes and displays the average spectrum for the selected time segment using infinite averaging . The spectrum plot is opened if necessary.

Expand Spectrogram - expands the spectrogram by recomputing the data for the selected time segment. An overlap percentage is used so that the entire time segment will fill the spectrogram plot.

Compute and Display 3-D Surface - computes and displays the 3-D Surface plot for the selected time segment using the current FFT size and averaging settings. An overlap percentage is used so that the entire time segment will fill the 3-D Surface plot. The 3-D Surface plot is opened if necessary.

Display Spectrum Plot - displays the underlying spectral data at the time corresponding to the current mouse position (same as double clicking).

Display Order Plot - displays the underlying order based spectral data at the RPM corresponding to the current mouse position (same as double clicking). RPM must the selected for the time series axis for this menu command to be available.

Properties - activate the display options dialog box.

Help - activates the online help.

See Also: Spectrum Plot , Time Series Plot , Phase Plot , Spectrogram Plot , 3-D Surface Plot


Printing the results

The program allows you to print one Plot at a time. Make the plot you wish to print the active window by clicking anywhere in the plot. Size the plot to display the information you wish to print; only the displayed data will be printed. Select the <Print> option from the <File> menu. Change any printer options and click OK.

The <File><Print Setup> menu command allows you to select various options specific to your printer.

Annotation: Two user defined lines of annotation are provided. These are centered along the top portion of the printout.

Margins: Set as desired.

Comments: You can include up to 10 comment lines which will be printed below the plot. A button allows you to copy the metadata into the comment block.

Notes:

  • For best results when printing the color spectrogram on a monochrome printer, select the grayscale option on the spectrogram options dialog box.
  • For printing the 3-D surface plot on a monochrome printer, you may wish to select a white background color and black line color from the 3-D Surface options dialog box.
  • Color printers are supported.
  • Pen Plotters are not supported for the spectrogram and 3-D surface plots

See also: Configuration Files


Toolbars

SpectraPLUS-DT contains the following toolbars:

Main Application Toolbar

Secondary Toolbar

Individual Plot Toolbars

To hide a toolbar click on the <Plots><Toolbars> menu.

See also: Basic Operation, Keyboard Shortcuts , Cursor Measurements


Status Bar

The status bar is located along the bottom edge of the application. It contains the status of key processing parameters:

The current values displayed in the status bar along the bottom of the application for the channel correspond to the plot which has the "focus" (its title bar is highlighted).

Run status (Stopped, Running etc).

Operating Mode

Sampling Format.

Active Channel (corresponds to the plot which has the "focus")

FFT size

Smoothing window


Keyboard Shortcuts

The main toolbar contains icons for controlling the processor. Each icon's label has one of the letters underlined. Pressing the <Alt> key and the underlined letter will perform the same action as a button press.

In the same way, keyboard shortcuts are available for each menu item. Pressing the <Alt> key and the underlined letter in the menu and sub-menu item will allow quick access to the commands.

Additional shortcut keystrokes called "accelerator keys" are available for selected menu items:

Accelerator keys:

F1 Help

F2 Run

F3 Stop

F4 Processing Settings dialog box

F5 Display Options dialog box

F7 Save Configuration File

F8 Load Configuration File

F11 Signal Generator Utility

Alt+R Run the Analyzer

Alt+S Stop the Analyzer

Ctrl+0 File Open

Ctrl+S File Save

Ctrl+A File Save As

Ctrl+P File Print

Alt+F4 Exit Application

Ctrl+Z Undo last edit

Ctrl+Del Edit Cut

Ctrl+Ins Edit Copy

Shift+Ins Edit Paste Insert

Ctrl+L Play Special - Loop

Other Special Keystrokes:

Pressing the return key or the (+) key in the post-processing mode will cause the analyzer to make a single measurement and then stop (single step). The averaging is not reset between steps.

Pressing the minus key (-) will cause the analyzer to step backwards in the file. The step size used corresponds to the current overlap percent setting.

Time Series plot must have the "focus" for these special keystrokes to function.

The Focus:

If you click the mouse on one of the scrollbars, that control then gains the "focus" and gains keyboard control. What this means is that you can then use the keyboard arrows to adjust its setting up and down. For example, clicking once on the Average control on the toolbar will then allow you to use the up/down arrow keys to adjust the averaging block size. The same is true for each of the scroll bars.

The Average size and Wave File position scrollbar control on the main toolbar as well as the lower status bar values showing FFT size, sampling rate, format and smoothing window values correspond to the channel which has the "focus" (its title bar is highlighted). If in doubt, the channel indicator reading on the lower status bar shows the channel number.

See also: Toolbar, Status bar


Opening and Saving Wave Files

Clicking one of the><New/Open/Save/Save As> menu items or clicking the corresponding toolbar button will activate the Wave File Management dialog box. This allows you to open, save or close up to 16 individual mono wave files. Stereo wave files can be opened and you will be asked which channel to analyze; however, recording will be disabled for that channel. Only the .WAV format is currently supported, however you may import raw data files from other acquisition systems using the File Import command.

Enable Recording - this option is only available in the Recorder Mode and controls whether or not the analyzer will record data from that specific channel or not. If no wave file is open the analyzer will record to an Untitled file. After recording the data you can either save the file or close it without saving.

When recording to a preexisting wave flie the sampling rate of the hardware must match the sampling rate of the wave file. This is because the .WAV file format requires a constant sampling rate throughout the entire file. The Post Processing mode allows you to process files that have different sampling rates.

When the mode is changed to Real-Time, the current files will be closed and you will be prompted to save it if necessary.

Save All Files Using a Prefix

Working with large numbers of files can be cumbersome. This feature allows you to specify a "Prefix" to be used as a pattern to quickly save all open files. The channel number will be appended to the Prefix - for example a prefix of "Project 451" will save files with names as follows:

Project 451_Ch_0.wav

Project 451_Ch_1.wav

Project 451_Ch_2.wav

Project 451_Ch_3.wav

etc...

The Channel Name* can also be included in the filename when using a prefix. Here are some examples:

Project 451_Accel_X_Ch_0.wav

Project 451_Accel_Y_Ch_1.wav

Project 451_Accel_Z_Ch_2.wav

Project 451_Mic_H2_Ch_3.wav

etc...

*The channel name is what is shown in the Calibration tab of the processing settings

Wave File Groups

You can Save and Load groups of wave files using the corresponding buttons on the bottom of the dialog box. This creates a small text file (.wfg extension) containing a list of open wave filenames for each channel. It is stored in the same folder as the wave files. This is helpful for recording and post processing large sets of wave files.

File Storage Requirements

The amount of memory required for each minute of data varies widely depending upon the sampling rate and sampling format. Some typical values for mono recording are shown below:

Sampling Rate (Hz) Sampling Precision (bits) Bytes/Minute

11,025 8 661,500

11,025 16 1,323,000

22,050 8 1,323,000

22,050 16 2,646,000

44,100 8 2,646,000

44,100 16 5,292,000

44,100 24 7,938,000

96,000 16 11,520,000

96,000 24 17,280,000

Continuous Recording Capability

Wave files can store up to 2 GB of data in a single file (the corresponding time depends upon the sampling format). When this limit is reached, the program will momentarily stop recording, save the file and then start recording again in a new file. If the file is does not yet have a name, the program will give it a name using the computer date and time. The file will be stored in the \wave folder as specified in the <File>< Set Paths > dialog. This feature applies to the hard disk recording mode only.

Example: c:\speclab\wave\recording_2010_11_26_102011.wav

(in this example the date and time were 10:20:11 Nov, 26 2010 when the file was saved)

See also: Recorder Mode , Importing Files, Exporting Files, Cut/Copy/Paste commands


Importing Files

Standard .WAV files are binary files containing a header followed by a block of data samples. The .WAV file header contains information about the sampling rate, number of channels, and number of bits per sample. Stereo files are interleaved (L,R,L,R...).

The import feature allows you to import raw digitized data from an external source and create a .WAV file from the contents. In order to properly build the WAV file header, you must specify the sampling rate represented by the data and the destination sampling format is.

File Formats:

  • ASCII Integer - File is readable with any text editor. For mono files, each line contains a single sample value. For stereo files, each line contains both the left and right sample values separated by a comma.
  • ASCII Float - File is readable with any text editor but the values are converted to floating point format (e.g. 21.034). For mono files, each line contains a single sample value. For stereo files, each line contains both the left and right sample values separated by a comma.
  • Binary 8 bit - 8 bit integer values.
  • Binary 16 bit - 16 bit integer values.
  • Binary 32 bit - 32 bit integer values.
  • Binary floating point - 32 bit floating point values.

Expected Sample Values:

  • 8 bit WAV data: 0...255
  • 16 bit WAV data: -32767...+32767
  • 24 bit Wav data -8388607...++8388607

File Header Options:

If the data file contains a header, you can specify the size of this header in lines (ASCII file) or bytes (binary file). This header data will be skipped during the import process.

Data Scaling:

  • If "rescale" is checked, the program will determine the maximum and minimum values contained in the file and rescale all values to optimally fit within the selected sampling precision.
  • If "truncate" is checked, the program will accept all values as is and truncate those which exceed the specified sampling precision.
  • Define Actual Data Values and Units - use this option if you know the units contained in the data file. This will create the calibration parameters for properly scaling the data file.

See also: Opening and Saving Wave files, Exporting Files, Sampling Format, Sampling Rate


Exporting Files

This feature allows you to export a .WAV file to a variety of file formats. These files can then be used with a spreadsheet, mathematical processing program, or you custom application.

Destination File Formats:

  • ASCII Integer - File is readable with any text editor. For mono files, each line contains a single sample value. For stereo files, each line contains both the left and right sample values separated by a comma.
  • ASCII Float - File is readable with any text editor but the values are converted to floating point format (e.g. 21.034). For mono files, each line contains a single sample value. For stereo files, each line contains both the left and right sample values separated by a comma.
  • Binary 8 bit - 8 bit integer values.
  • Binary 16 bit - 16 bit integer values.
  • Binary 32 bit - 32 bit integer values.
  • Binary floating point - 32 bit floating point values.
  • Universal File Format - type 58 ascii
  • Universal File Format - type 58 binary

Output Sample Values:

  • 8 bit WAV data: 0...255
  • 16 bit WAV data: -32767...+32767
  • 24 bit WAV data: -8388607...+8388607

Notes:

  • When exporting stereo files, the channels are interleaved starting with the left channel.
  • Binary files are much more efficient than text files; ASCII text format is not recommended for large files.
  • If you wish to export a small time segment from within a large .WAV file, use the time series plot to specify the selected segment and then use the <Edit> <Copy> menu item to place the segment on the clipboard. Next, close the file and create a new file by pasting in the selected time segment using the <Edit> <Paste Insert> menu command. Then export this smaller WAV file.
  • Exporting a 16 bit WAV file to either a ASCII or Binary 8 bit file will rescale the data to fit within the 8 bit sample range.
  • The Universal File Format allows you to export multiple wave files to a single UFF file
  • For more information on the Universal File Format type 58 go to www.sdrl.uc.edu

See also: Opening and Saving Wave files, Importing Files , Sampling Format, Cut/Copy/Paste Commands


File Options

File options allow you to control how .WAV files are stored and accessed.

Access modes:

  • RAM - All Wave data must fit in the available RAM.
  • Hard Disk - Wave data is recorded and played back directly from your hard disk. This allows much greater recording times. You can specify the maximum recording size in megabytes (wave files can store up to 2 GB of data in a single file - the corresponding time depends upon the sampling format).

Make Backup:

This option applies to hard disk access mode only. When this option is checked, a temporary backup file will be created so that original file contents can be restored if necessary. Use the <File><Set Paths> menu command to specify the directory to be used for these temporary files. All backup files are removed when the application closes.

Include Calibration Data in WAV file

If this option is enabled, the calibration parameters will be included in the WAV file and reloaded when the file is opened again. This is enabled by default. The calibration parameters will not add significantly to the file size. Most applications that work with WAV files wil not have a problem with this additional data but many will not preserve the cal data when saving the file. The only reason you should need to disable this option is if you encounter an application that has problems reading WAV files with the calibration data.

Include Time Stamp Wave file

If this option is enabled, time stamp information is stored in the file. This is based on the PC time when the recording was started.

Apply Time Stamp to Plots

If enabled, the time stamp information will be used on the time axis of the Time Series, Spectrogram and 3-D Surface plots.

Include Metadata in Wave file

If this option is enabled, user supplied metadata is stored in the file. Click the <Edit><Metadata> menu to enter or view the metadata.

Prompt for Metadata when saving file

If enabled, the <Edit><Metadata> dialog box will be displayed when saving a wave file for the first time.

Automatically reopen WAV files when program launches

If enabled, the analyzer will reopen any wave files that were left open when the program exits.

Real Time Mode Data Buffering

This option allows you to control whether data is buffered in the real time mode or not. Data buffering will allow the spectrogram or 3-D surface plots to be redrawn to correspond to changes in scaling parameters or plot size and allows you to use the right click action menus to perform additional processing. In addition, you can convert this data buffer to a WAV file for further processing in the post-processing or recorder modes. This option is enabled by default and should prove useful in most situations. Turning this option off will result in a slight performance gain but this gain is minimal with adequate memory and hard disk space. The data buffering will use the same file access method (RAM or Hard Disk) as selected above.. The default buffer length is 60 seconds but can be changed as necessary.

Continuous Recording Capability

When Hard Disk recording is used and the maximum file size limit is reached, the program will momentarily stop recording, save the file and then start recording again in a new file. If the file is does not yet have a name, the program will give it a name using the computer date and time. The file will be stored in the \wave folder as specified in the <File><Set Paths> dialog. This feature applies to the hard disk recording mode only.

Example: c:\speclab\wave\recording_2002_11_26_102011.wav

(in this example the date and time were 10:20:11 Nov, 26 2002 when the file was saved)

Notes:

  • When working with small files, RAM access will provide faster performance. Hard Disk access is preferred for larger files.
  • During hard disk recording sessions, do not perform other disk intensive operations (such as opening a major application). Although Windows is a multitasking operating system, it relies on the cooperation of individual applications and cannot guarantee immediate access to system resources.

See also: Opening and Saving Wave files, Recorder Mode


Set Paths

This option allows you to customize the default file directories for each of the file types utilized by the software.

Set or Create All Paths - this allows you to easily change all the file paths without having to edit each one. If the specified folder is not found it will be create along with the underlying data folders.

Set Defaults - restores the data paths to their original installed location (typically \My Documents\User\SpectraPLUS_DT)


Configuration Files

The <Config> menu contains commands which allow you to save the current analyzer configuration and to load previously stored configurations from disk.

Configuration files contain all analyzer options as well as position and size information for each open plot. The default file extension for configuration files is .CFG. The file is in same standard ASCII text format used for INI files

Configuration files can be quickly loaded from the main toolbar by selecting the desired file from the drop down list labeled "Load Configuration".

Automatically Opening a Configuration file

If you create a shortcut to the application and pass in the filename of a configuration file it will automatically be opened. To set this up right click on the shortcut icon and select the Properties menu item - edit the "Target" field of the shortcut details. For example C:\SpectraPLUS_DT\Bin\SplusDT.exe Test1,cfg - this will load the Test1 configuration file when the shortcut is used.

Multiple shortcuts can be created for each test configuration. In addition, multiple instances of the application can run at the same time to support multiple DT-9800 hardware modules.


Cut/Copy/Paste commands

The Cut/Copy/Paste commands are used to place the contents of the active plot onto the clipboard. The format of the resulting clipboard data differs depending on the active plot:

Plot Cut Copy Paste

Spectrum N/A ASCII table N/A

Phase N/A ASCII table N/A

Time Series .WAV format .WAV format .WAV format

Spectrogram .WAV format .WAV format .WAV format

3-D Surface .WAV format .WAV format .WAV format

When using the Time Series, Spectrogram, or 3-D Surface plots, you must first select the time segment which you want to edit. To do this, simply click the selection arrow tool on the left edge of the plot toolbar. Next, click and drag across the plot area with the left mouse button to highlight the time segment you wish to edit. At this point the Edit commands will be enabled to allow you to select the desired operation. These commands are always disabled when in the real-time mode since no underlying data exists.

The .WAV format is compatible with any application which supports .WAV files.

The ASCII table format produces two columns of numbers with the bin frequency in the left column and the amplitude or phase in the right column. The columns are separated by a tab. You can then paste this data into a spreadsheet or text editor for further analysis. It is also compatible with both the spectral overlay and mic compensation file formats.

The <Undo> <Edit> command allows you to reverse the most recent editing action. This includes the: <Edit> <Cut, <Edit <Paste Over>, <Edit <Paste Insert> and <Edit Filter> commands.

See also: Opening and Saving Wave files, toolbar


Play/Play Special commands

The Play and Play Special menu commands allow you to playback a selected time segment so you can hear it through your speakers.

You must first select the time segment which you want to edit. This can be done from either the Time Series, Spectrogram, or 3-D Surface plots. First, click the selection arrow tool on the left edge of the plot toolbar. Next, click and drag across the plot area with the left mouse button to highlight the time segment you wish to edit. At this point the Edit commands will be enabled and allow you to select the desired operation.

The <Edit> <Play> menu item plays the selected segment through the currently selected output device .

The <Edit> <Play Special> menu has four choices:

Loop - continuously plays the selected time segment (click the Stop button to cancel).

Half speed - plays the selected time segment at 1/2 the normal sampling rate.

Double speed - plays the selected time segment at 2 times the normal sampling rate.

Arbitrary speed - plays the selected time segment at the user specified sampling rate

See also: Opening and Saving Wave files, toolbar


Filtering

To filter a .WAV file, you must first select a time segment. This is done from either the Time Series, Spectrogram, or 3-D Surface plot. Click the selection arrow located on the plot toolbar and then click and drag the mouse across the desired time segment. This segment will then be displayed in inverse video. Once the time segment has been selected, press the filter button on the toolbar or select the <Edit><Filter> menu command. The filtering parameter dialog box will then allow you to select the frequencies to be filtered.

There are five filter types:

  • Low Pass - passes all frequency components below the specified cutoff frequency and attenuates all components above it.
  • High Pass - passes all frequency components above the specified cutoff frequency and attenuates all components below it.
  • Band Pass - passes the specified band of frequencies and attenuates all others.
  • Notch - rejects the specified band of frequencies and passes all others.
  • Custom - applies the specified filter response file to the data.

Filter Sharpness - the number of filter taps (coefficients) directly affects the sharpness of the filter response and how closely it matches the ideal response. More taps produce a sharper filter response but require more processing time.

Filter Gain - allows the overall gain to be adjusted. Enter a value in dB; use a positive value to increase the gain, negative to decrease.

Building a filter response file:

  • Run the NOTEPAD.EXE application, spreadsheet or word processor that can produce a standard ASCII text file.
  • Enter two columns of numbers representing the filter response curve.
  • The left column contains the frequency in Hertz.
  • The right column contains the offset in decibels
  • Enter the information in ascending frequency order.
  • Separate the columns with a tab character.

Example:

---------------------------

100.0 -10.0

500.0 -5.0

1000.0 0.0

2000.0 2.0

10000.0 -5.0

15000.0 -15.0

Enter as many as32,768 pairs of numbers; at least 3 pair are required. The analyzer will use a cubic spline algorithm to interpolate between these data points for each frequency in the spectrum. Any line with a semicolon in the first column will be treated as a comment line and ignored. By convention, filter response files have an extension of .FLT.

Note:

Filter Response files, Transdcuer Compensation files, and Overlay files have identical formats and can be interchanged. This is useful if you want to verify that you have entered the filter response table correctly. To do this, simply select load the filter response file into one of the overlays for display.

The default folders used for storing the various files used by SpectraPLUS-DT can be customized by clicking on the <File>< Set Paths > menu item.

See also: Opening and Saving Wave files, toolbar


Mute

Muting a time segment will set the values to zero.

To mute a segment of a .WAV file, you must first select a time segment. This is done from either the Time Series , Spectrogram , or 3-D Surface plot. Click the selection arrow located on the plot toolbar and then click and drag the mouse across the desired time segment. This segment will then be displayed in inverse video. Once the time segment has been selected, select the <Edit><Mute> menu command. The samples corresponding to the selected time segment will be set to zero.

Notes:

The <Edit><Undo Edit> menu command will restore the data to its original values.

See also: Opening and Saving Wave files , toolbar


Select All

The Select All menu command will cause the contents of the time series , spectrogram and 3-D Surface plots to be selected (highlighted) for additional editing.

Notes:

If you wish to select the entire .WAV file for editing, first use the Zoom Out Full button on the time series toolbar. You may also need to increase the maximum zoom limit in the time series options dialog.

See also: Opening and Saving Wave files , toolbar


Gain Adjust

To adjust the gain of a .WAV file, you must first select a time segment. This is done from either the Time Series , Spectrogram , or 3-D Surface plot. Click the selection arrow located on the plot toolbar and then click and drag the mouse across the desired time segment. This segment will then be displayed in inverse video. Once the time segment has been selected, select the <Edit><Gain Adjust> menu command. You will then be prompted enter the the amount of gain in decibels (dB) to add or subtract. Click the OK button to perform the adjustment.

Notes:

The <Edit><Undo Edit> menu command will restore the segment to its previous value.

See also: Opening and Saving Wave files , toolbar


DC Offset

To adjust the DC Offset of a .WAV file, you must first select a time segment. This is done from either the Time Series , Spectrogram , or 3-D Surface plot. Click the selection arrow located on the plot toolbar and then click and drag the mouse across the desired time segment. This segment will then be displayed in inverse video. Once the time segment has been selected, select the <Edit><DC Offset> menu command. You will then be prompted enter the the amount of DC Offset to add or subtract. The offset is entered in units according to the current calibration settings. Click the OK button to perform the DC Offset.

Notes:

The <Edit><Undo Edit> menu command will restore the segment to its previous value.

See also: Opening and Saving Wave files , toolbar , Dynamic DC Offset


Dynamic DC offset

This feature will compute an average offset of the waveform and subtract it from the time series. This will dynamically remove a DC offset instead of just applying a fixed offset.

To apply the Dynamic DC Offset algorithm to a file, you must first select a time segment. This is done from either the Time Series , Spectrogram , or 3-D Surface plot. Click the selection arrow located on the plot toolbar and then click and drag the mouse across the desired time segment. This segment will then be displayed in inverse video. Once the time segment has been selected, select the <Edit><Dynamic DC Offset> menu command. You will then be prompted enter the the Dynamic DC Offset parameters. Click the OK button to perform the computation.

Parameters:

Cufoff Frequency - This determines the filter cutoff frequency. Lower frequencies require longer computation times.

Recalculation Interval - This controls how frequently the offset is recalculated. Lower intervals require longer computation times.

Notes:

The <Edit><Undo Edit> menu command will restore the segment to its previous value.

See also: Opening and Saving Wave files , toolbar , DC Offset


Metadata

Metadata can be stored in the wave file. Click the <Edit><Metadata> menu to enter or view the metadata.

Metadata is a block of up to 2000 ascii text characters that can be used for notating test conditions or other comments about the wave file.

A wave file must be open in order to edit or view metadata. If you are in the Recorder mode you must start a recording before you can enter metadata.

The option "Show this dialog box before saving wave file" will cause the analyzer to automatically prompt for metadata when saving a new recording.

Note: The metadata can be printed on the comments section of the plots - see the <File><Annotation and Margins> dialog box.


Real-Time Mode

In the real-time mode, the program acquires an FFT sized block of digitized analog data directly from the input device, computes the spectrum and displays the results. The program will continuously acquire new data, average it with previous data, and display the results until stopped. The toolbar contains controls to allow you to modify the averaging and peak hold while running.

By default, the last 60 seconds of digitized data is stored in a temporary buffer. Switching to the Recording or Post Processing modes will allow you to convert this buffer into a WAV file for further processing.

Notes:

Depending upon the speed of your CPU, the selected sampling rate, number of channels and FFT size and plots, the computer may not be able to perform an FFT on the current data block and display the results before the next block is available. In this case, there will be gaps in the processed data. To perform gap free analysis, simply record the signal and analyze the data using the post-processing mode.

Often it is useful to run the analyzer in the Real Time mode while making preliminary measurements and then switching over to the Recorder mode before making the final measurements.

See also: Basic Operation , Performance Issues , Settings


Post-Processing Mode

The post-processing mode allows you to analyze one or more previously recorded WAV files. The priority is given to spectral updates and the data is not played back through the speakers. For playback, use the Edit Play/Play special commands.

This mode provides greater control over the processing than the Recorder or Real-Time modes. There will be no gaps in the processed data, and you can "stretch" the time axis on the Spectrogram and 3-D Surface Plots by performing overlap processing . In addition you can edit and playback selected time segments which allows in-depth analysis not possible in the real-time mode.

When a .WAV file is opened, the original sampling rate and format are read from the file and are used during processing - the sampling rate must remain constant within a single .WAV file. The current sampling rate is always displayed in the status bar along the bottom of the application for the channel corresponding to the plot which has the "focus" (its title bar is highlighted).

Single step operation:

Pressing the <Enter> key or (+) will perform a single FFT measurement and then automatically stop the analyzer (single step measurement). The current average is not reset during single step operations.

Pressing the minus key (-) will cause the analyzer to step backwards in the file. The step size used corresponds to the current overlap percent setting.

Time Series plot must have the "focus" for these special keystrokes to function.

See also: Basic Operation , Overlap Percentage , Performance Issues , Opening and Saving Wave Files


Recorder Mode

This mode allows you to record one or more input channels to individual mono WAV files. The analyzer will also display the spectrum of the signal while recording is in progress.

When using the RAM file access mode, the program will attempt to allocate enough memory for the recording and will reduce the recording length if not enough memory is available. The recording length is specified in the File Options dialog box.

When using the Hard Disk file access mode, the program will record directly from your hard disk. Temporary files are created during hard disk recording. Use the <File><Set Paths> menu command to specify the directory to be used for these temporary files. All temporary files are removed when the application closes.

When a .WAV file is opened, the original sampling rate and format are read from the file. The current sampling rate is always displayed in the status bar along the bottom of the application for the channel corresponding to the plot which has the "focus" (its title bar is highlighted).

Continuous Recording Capability

Wave files can store up to 2 GB of data in a single file (the corresponding time depends upon the sampling format). When this limit is reached, the program will momentarily stop recording, save the file and then start recording again in a new file. If the file is does not yet have a name, the program will give it a name using the computer date and time. The file will be stored in the \wave folder as specified in the <File><Set Paths> dialog. This feature applies to the hard disk recording mode only.

Example: c:\spectra\wave\recording_2010_11_26_102011.wav

(in this example the date and time were 10:20:11 Nov, 26 2010 when the file was saved)

Important:

During hard disk recording sessions, do not perform other disk intensive operations (such as opening a major application). Although Windows is a multitasking operating system, it relies on the cooperation of individual applications and cannot guarantee immediate access to system resources.

See also: Basic Operation , Sampling Rate, Device Options , Opening and Saving Wave Files


Time Series Plot

This plot displays the raw digitized analog data and is similar to an oscilloscope display with the amplitude shown on the vertical axis and time on the horizontal axis.

When you are using the Real-Time mode, the plot will display the lastest 60 seconds of acquired data. In the Recorder or Post-Processing modes you may zoom and scroll through the entire data file using the toolbar and scrollbar controls. The horizontal scaling is in seconds relative to the start of the file. Double clicking with the left mouse button anywhere in the plot will move the current file position to the pointer location. In addition, the spectrum corresponding to the new pointer location will be computed and displayed in the spectrum plot.

In the Recorder or Post-Processing modes you may zoom and scroll through the entire data file using the toolbar and scrollbar controls. The horizontal scaling is in seconds relative to the start of the file. Double clicking with the left mouse button anywhere in the plot will move the current file position to the pointer location. In addition, the spectrum corresponding to the new pointer location will be computed and displayed in the spectrum plot.

Toolbar Controls

Time Series Plot Options

Cursor Measurements

Right Click Action Menus

See also: Performance Issues


Spectrum Plot

This plot is a 2 dimensional plot of the spectrum. The horizontal axis shows the frequency in Hertz (Hz). The vertical axis shows the amplitude of each frequency line. The amplitude scaling type can be modified using the <Options><Settings> menu and clicking on the Scaling tab or by clicking the corresponding toolbar button.

The total number of available spectral lines is always equal to the FFT size / 2. Thus for a 1024 point FFT here will be 512 spectral lines. The measurement will always start at 0 Hz and extend to 1/2 of the selected Sampling Rate .

The maximum displayed spectrum is limited on the low and high ends. The lowest 3 bins contain a DC component and are not displayed; the top 1% of the span often contains alias components and therefore is not displayed.

The zoom buttons on the toolbar allow you to easily adjust the displayed span within the available measurement span; however, the FFT algorithm requires that all frequency lines must be computed regardless of whether or not they are displayed.

The mouse can be used to directly measure the frequency and amplitude information directly off the plot. In addition, the <Edit><Copy> menu item will place the current spectral data on the clipboard in tabular format. This can be directly pasted into any spreadsheet or text file.

Toolbar Controls

Spectrum Plot Options

Spectral Overlays

Cursor Measurements

Right Click Action Menus

See Also: Scaling Measurement Accuracy , Performance Issues


Phase Plot

This plot displays the phase of the signal versus frequency. It is most useful when examining the phase difference between the right and left channels using a Transfer Function. To do this, select the <Plots><Select Composite Channel Plots> menu command.

The frequency scaling is governed by the current scaling options. The zoom controls located on the toolbar can be used to adjust the displayed frequency span anywhere within the measurement range.

The mouse can be used to measure the frequency and phase information directly off the plot. In addition, the <Edit><Copy> menu command will place the current phase data on the clipboard in tabular format. This can then be directly pasted into any spreadsheet or text file.

The phase is greatly affected by the choice of smoothing window. Selecting "Uniform" will produce the cleanest phase response.

Toolbar Controls

Phase Plot Options

Cursor Measurements

Right Click Action Menus

See Also: Scaling , Measurement Accuracy , Performance Issues


Spectrogram Plot

This plot displays the spectral data over time with the amplitude shown in color. For some users, this display is difficult to interpret, but with a little practice it is one of the most useful displays available for spectral analysis. Simply think of it as if you were looking down on the 3-D Surface plot and that the amplitude is shown in color. The color bar to the right of the plot shows the amplitude/color relationship.

Double clicking the left mouse button within the spectrogram will display the corresponding spectral and time series data in their respective plots.

Toolbar Controls

Spectrogram Plot Options

Cursor Measurements

Right Click Action Menus

See Also: Scaling , Measurement Accuracy


3-D Surface Plot

This display is a perspective plot of the spectral data over time. Frequency is shown on the X-axis and time on the Y-axis. This plot is useful for visualizing the dynamics of the spectral data.

Double clicking with the left mouse button within the plot will display the corresponding spectral and time series data in their respective plots (if they are open).

Toolbar Controls

3-D Surface Plot Options

Cursor Measurements

Right Click Action Menus

See Also: Scaling , Measurement Accuracy


Selecting Single Channel Plots

Click the <Plots><Select Single Channel Plots> menu to select the plots you want to use for each enabled channel. You can also access this dialog box by pressing the corresponding toobar button or the F5 function key.

The channel must be enabled or have an open wave file associated with it before you can select plots. Up to 16 channels can be selected. Channel indexes use numbers 0-15 to correspond to the DT-9800 hardware channel numbering.

Plot types

Time Series

Spectrum

Phase

Spectrogram

3-D Surface

See Also: SeeSelecting Composite Channels


Composite Channel Processing Options

Composite Channel Processing

Composite channel spectrum analysis provides several very powerful advanced measurements.

Click the <Plots><Select Composite Channel Plots> menu to setup composite channel operations. Up to 16 composite channels can be defined. Composite channels indexes use letters A-P instead of numbers.

Definitions

Auto-spectrum - calculated by multiplying a spectrum by its complex conjugate (opposite phase). The auto-spectrum is real and is identical to the magnitude response. The auto-spectrum is what is normally displayed in a single channel spectrum plot .

Cross-spectrum - calculated by multiplying one spectrum by the complex conjugate of a second spectrum. The cross-spectrum is a complex quantity (has both real and imaginary components). The magnitude of the cross-spectrum represents the amount of power common to both channels, and the phase represents the phase difference between channels. For example, If two identical signals are 180 degrees out of phase, the magnitude of the cross spectrum is zero. If two channels are identical, their cross-spectrum is equal to the auto-spectrum of either channel alone.

Transfer Function - is the ratio between two channels and can be computed in one of two ways:

Real - this is the simplest method and is simply the ratio between the auto-spectrum (magnitude) of each channel. The relative phase of each channel does not contribute to the result.

Complex - this is the ratio between the cross-spectrum of the two channels and the auto-spectrum of the reference channel. The relative phase of each channel contributes to the result.

The transfer function is a very powerful feature. It allows you to quickly and accurately compute the frequency response of a device under test. See the topic " Transfer Function " topic for more setup information

Coherence Function - is the ratio of the squared magnitude of the cross-spectrum and the product of the auto-spectrum of both channels. It measures the degree of linearity between the channels and is analogous to the squared correlation coefficient used in statistics. Two perfectly coherent signals have a coherence value of 1.0

Composite Measurement Type:

  • Average Multiple Channels - averages the auto-spectrum of two or more source channels.
  • Real Transfer Function - computes and displays the real transfer function between any two source channels (test vs reference)
  • Complex Transfer Function - computes and displays the complex transfer function between any two source channels (test vs reference)
  • Complex Transfer Function and Coherence - computes and displays the complex transfer and the coherence between any two source channels (test vs reference)
  • Cross Spectrum - computes and displays the cross-spectrum of any two source channels.
  • Difference - computes and displays the magnitude and phase differnces by subtracting the source channels spectral data

Notes:

- These do not apply to the time series plot .

- The source channels must have the same sampling rate, format and selected FFT sizes.

- The scaling used on the composite plots is as follows:

Average multiple channels: same as scaling selected for the first channel in the average list

All other types: same as the scaling selected for the "test channel"

See Also: Settings , Sampling Format


Input Device Settings

The Input Device is used by the analyzer when Recording or running in the Real Time mode.

Click the <Options><Processing Settings> menu (or press F4) and select the "Input" tab to access the input device settings. You can also click the I/O toolbar button to access these settings.

All DT-9800 hardware modules that are currently connected to your computer are shown in the device list. The analyzer will communicate with the selected device and determine which settings are adjustable. Not all DT-9800 devices support all settings; some of the device settings will be disabled or have only one possible selection. Consult your hardware documentation for details.

Enable: controls which input channels are enabled for Real Time analysis or Recording.

Input Range: selects the input voltage range (gain) used by the device. This value is in volts (peak). A signal exceeding this level will overload (clip) the input. Overloaded channels are shown in red on the lower status bar. Not all DT-9800 devices support adjustable input gain.

Input Coupling: selects whether the input channel is AC or DC coupled. AC coupling is typically used for most audio and vibration applications. Not all DT-9800 devices support this feature.

IEPE Current: controls whether or not IEPE (constant current) power is turned on. IEPE is used by many transducers (microphones and accelerometers) and eleminates the need for external power supplies. This reduces cost and simplifies wiring. Not all DT-9800 devices support IEPE power.

Low Pass Filter: controls whether or not a low pass filter is applied prior to the digitizer. Not all DT-9800 devices support this feature.

Sampling Rate: Selects the sampling rate to use for all enabled channels. The same sampling rate applies for all channels.

The DT-9800 family of devices fall into two categories 1) Sequential Sampling and 2) Simultaneous Sampling.

Sequential sampling - one digitizer is used for all channels. Each channel is sampled at a slightly different instant of time as the digitizer cycles through all enabled channels. In addition, the maximum sampling rate per channel is equal to the maximum device sampling rate divided by the number of enabled channels. For example, if the maximum hardware rate is 500 kHz and 10 channels are enabled, each channel can sample at a maximum of 50 kHz. If two channels are enabled then the maximum per channel rate is 250 kHz. The "Aggregate Rate" is the per channel rate multiplied by the number of enabled channels.

Simultaneous sampling - a separate digitizer is used for each channel. All channels are sampled at the same instant of time. Each channel can be sampled at the maximum device sampling rate.

Sampling Resolution: This specifies the number of discrete levels that are used in the analog to digital (A/D) conversion process and directly affects the dynamic range of the measurement. The list will only contain the sampling resolutions supported by the selected DT-9800 device.

Analog Input Type: selects whether the input channels are "Single Ended" or "Differential". Not all DT-9800 devices support differential inputs.

Single Ended - input channels have a common signal ground.

Differential input channels - input channels have isolated signal ground. This provides maximum immunity from common mode voltage (ground noise). When differential input type is selected the total number of available input channels is reduced by 1/2. Consult your hardware documentation for wiring details.

See Also: Tachometer Channel


Output Device Settings

The Output Device is used by the analyzer for wave file playback and for signal generaton. Since not all DT-9800 devices support D/A operations you have the option of using standard multimedia sound cards.

Click the <Options><Processing Settings> menu (or press F4) and select the "Output" tab to access the output device settings. You can also click the "Level" button on the Signal Generator utililty to access these settings.

All DT-9800 hardware modules and sound cards that are currently connected to your computer are shown in their respective device lists.

Sampling Rate: specifies the sampling rate used by the signal generator. During wave file playback the sampling rate specified in the wave file is used instead.

Channels: specifies the number of channels used by the signal generator. During wave file playback only one channel is used.

Bits Per Sample: specifies the sampling precision used by the signal generator. During wave file playback the sampling precision specified in the wave file is used instead.

Channel Levels: specifies the output level for each channel used by the signal generator. This signal level applies to pure tone signal types (non noise).

Output Units: specifies the output level units. When a sound card is selected as the output device the output units are relative to the full scale output of the card. When the DT-9800 device is selected the output units can be directly set in engineering units.


FFT Settings

FFT Size

Smoothing Window

Averaging Settings

Overlap Percentage

Decimation Ratio


Scaling

You can control the scaling method for both the frequency and amplitude axis for each analyzer channel. These selections apply to all displays except the Time Series Plot and the Y axis on the Phase display.

Amplitude Axis Scaling

Frequency Axis Scaling

Power Spectral Density (PSD)

Standard Frequency Weighting

Transducer Compensation

See Also: Measurement Accuracy


Triggering

When triggering is enabled, the processor will test for a valid trigger condition before performing an FFT.

Trigger Mode: Controls the behavior of the analyzer after a trigger event occurs:

  • Rearm and wait for next trigger - process the current trigger event and wait for the next event. This is the default action.
  • Stop the analyzer - process the current trigger event and then stop the analyzer.
  • Continue running or recording - process the current trigger event and then run/record without waiting for any additional trigger events to occur.

Trigger Source: Analog channel - tests the specified analog input channel for the presence of the specified trigger conditions. External Trigger TTL - waits for the occurence of a TTL signal (+5.0 V) on the dedicated external trgigger input channel of the DT-9800 hardware (not all modules provide an external trigger channel).

Trigger Channel: specifies the analog input channel to test for the specified trigger condition.

Trigger Type: sets the type of trigger event to test for. Level triggering - a value meeting or exceeding the threshold. Edge triggering - a difference in level between any two sucessive samples that exceeds the threshold. Edge triggering is most useful with pulse type signals.

Trigger Polarity: controls whether the trigger threshold is a positive or negative value.

Threshold: Sets the trigger threshold. The threshold units correspond to the current calibration units.

Trigger Delay: adjusts the trigger position within the FFT block.

Trigger Delay/Type: can be used to adjust the acquisition window within the FFT block. Pre-delay will move the trigger point to the right, post-delay to the left. If the delay is set to zero, the trigger point is positioned at the start of the FFT data block. The delay value can be specified in milliseconds or as a percent of the FFT size.

Prompt User to Accept/Reject Trigger Waveform:

causes the analyzer to display a message box asking the user to accept or reject the current trigger event. The current trigger event will be shown in the time series plot for preview. If accepted the spectral data will be computed and averaged with previous data. If rejected, the trigger event will be discarded and the analyzer will continue waiting for an other trigger condition.

This is very useful for impact testing. It allows the user to preview the trigger waveform to verify that the impact hammer did not bounce. You can also use the Run Control options to set the number of FFT's to perform before stopping. Only accpeted triggers will result in an FFT being performed.

Pressing Cancel on the message box will stop the analyzer.

Note

When triggering is enabled, the analyzer may appear not to work if the signal stays below the threshold. Check the status bar along the bottom edge of the program for the current trigger status.


Calibration

Click the <Options><Processing Settings> menu (or press F4) and select the "Calibration" tab to access the calibration settings. You can also click the corresponding toolbar button to access these settings.

By default, the analyzer is calibrated to units of volts. The calibration options allow you to calibrate the analyzer to a wide range of engineering units.

Enable: if disabled the analyzer will be uncalibrated and the amplitude values will be in units of "Percent Full Scale" or "dB Full Scale" where 0 dB is the clipping point of the waveform. Calibration is enabled by default.

Calibration File: selects which calibration file to apply. The filenames "Volts" and "Millivolts" are reserved names and always available. Any user created calibration files will be added to this list.

File Edit/New: allows you to create or edit a calibration file.

There are three calibration methods:

1) Directly specify transducer sensitivity - select the transducer type and then enter its actual sensitivity. For example, 45 mV/PA for a microphone (consult your transducer calibration sheet for this information).

2) Calibrate to an external source - this allows you to calibrate to a known external reference. With this information we can conpute the correct scale factors. Here is the procedure:

  • Connect a steady state reference pure tone (such as a mic calibrator) to the input of the selected channel (do not use a DC level or noise signal).
  • Select the applicable units for the reference signal or select "Custom" and enter the axis labels to the right.
  • Enter the actual reference signal level value in the edit control (for example 94.0 dB SPL)
  • Select the reference signal type: "Peak", "RMS" or "Peak to Peak" as appropriate (mic calibrators produce RMS values)
  • Press the "Measure External Signal" button. The analyzer will then measure and display the voltage and frequency. Wait for it to stabilize. The analyzer will then compute the corresponding scale factors.

3) Calibrate to a Wave File containing a calibration signal - will compute the calibration scale factors from an existing wave file

  • Select the applicable units for the reference signal or select "Custom" and enter the axis labels to the right.
  • Enter the actual calibration signal level value in the edit control (for example 94.0 dB SPL)
  • Select the reference signal type: "Peak", "RMS" or "Peak to Peak" as appropriate (mic calibrators produce RMS values)
  • Press the "Measure From Wave File" button. The analyzer will then process the contents of the selected wave file and display the detected level (percent full scale).

Please note that this option is intended for a situation where you are Post Processing wave files that were captured on non DT hardware and where you also have a wave file with a calibration signal of known level. Do not use this option for recording new files as the calibration reference file recording gain is not known.

Converting Acceleration to Velocity or Displacement:

If you are calibrating to units of Acceleration the "Convert Acceleration To" field will activate and allow you optionally convert the spectrum to velocity or displacement. These conversions do not apply to the time series display.

You may customize the amplitude axis labels by directly modifying them in their respective edit boxes.

Channel Name: Enter a name for the channel - this is shown on all plots and utilities to help identify the signal.

See also: Scaling, Transducer Compensation Settings ,


Run Control

The Run Control options are used by the analyzer in all modes.

Click the <Options><Processing Settings> menu (or press F4) and select the "Run Control" tab to access the input device settings. You can also click the "Run Ctrl" toolbar button to access these settings.

Run continuously until Stop button is pressed: this selection is the normal operation and allows the analyzer to run or record continuously until stopped

Stop after N FFT's have been processed: causes the analyzer to automatically stop after the specified number of FFT's have been performed.

Stop after N seconds of data have been processed: causes the analyzer to automatically stop after the specificied time limit has expired.

Delay processing until N seconds have elapsed: causes the analyzer to discard the initial time period. This is useful for avoiding startup transients in some test scenarios.

Start all other copies of SpectraPLUS-DT that are open on this computer: causes the analyzer to send a run command to all other instances of the analyzer. This allows you to run multiple copies of the analyzer on the same computer to increase the channel capacity. Please note that each instance must have a difference input device selected for this to feature to work. When this option is enabled the Run or Record button will be outlined in red.

Enable the Spacebar key to toggle between Run and Stop: allows quick run/stop control from keyboard.

Analyzer Update Interval: Controls the time between each FFT update. Allows you to "slow down" the analyzer to better view the spectral changes over time. Enter the interval in milliseconds. This feature is only available in the Post Processing Mode.


Signal Generator

The signal generator utility produces a variety of test signals. Selecting the <Utilities><Signal Generator> menu command or pressing the F11 key will launch the signal generator.

The generator operates with the D/A channel of the DT-9800 module. Because not all modules support D/A operations you can also select to use your Windows compatible sound card as the output device. Press the "I/O Settings" buton on the generator to quicly access the Output Device Settings .

Basic Operation

  • Select the type of waveform you wish to generate by clicking on the list of waveforms.
  • Click the "Details" button to modify the specified waveform (not all waveform types have user options).
  • Click the "I/O Settings" button to specify the generator output level .
  • Click the "Run" button to start the generator.
  • When the generator is running, the window will change to show only a single "Stop" button.

Waveform types

White Noise

Pink Noise

Noise Burst

1 kHz Tone

Multiple Tones

Tone Burst

IMD Test Tones

Frequency Sweep

Frequency Step

Level Sweep

Sawtooth

Triangular

Pulse

Square

User Defined

DTMF

Digital Zero

Save Signal To Wave File

Clicking the <Utilities>< Save Signal To Wave File > menu will allow you to capture the current raw signal waveform to a wave file.

See Also: Output Level , Device Options , Save Signal To Wave File,


Save Signal To Wave File

This menu command creates a .WAV file from the current signal generator waveform. The signal generator utility must be activated before you can use this command.

You will be given the option of modifying the length of the resulting wave file by repeating the signal multiple times; you will then be prompted for the filename that will contain the waveform data.

This is useful for creating a custom waveform sequence. Simply create individual wave files with the various components (tone, noise, sweep, pulse etc) and then use the editing capabilities to construct a single wavefile with the signals and timing you need. Then use the User Defined signal type to load this custom file.

See Also: Signal Generator , User Defined Waveform


Peak Frequency

The peak frequency utility will display the frequency of the strongest spectral component in the entire span (not just what is displayed). This utility window can be resized as required by the user and its contents will update anytime a new spectrum is computed. The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Note:

Right clicking on the utility window will allow you to copy the contents to the clipboard.


Peak Amplitude

The peak amplitude utility will display the amplitude of the strongest spectral component in the entire span (not just what is displayed). This utility window can be resized as required by the user and its contents will update anytime a new spectrum is computed. The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Note

Right clicking on the utility window will allow you to copy the contents to the clipboard.


Total Power

The total power utility will display the total RMS power level for the entire spectrum and is equal to the total power bar on the right side of the spectrum plot. The weighting (Flat, A, B or C) used for this utility is set under the Scaling options dialog box. This is equivalent to the readings on a Sound Level Meter with calibrated to units of SPL.

This utility window can be resized as required by the user and its contents will update anytime a new spectrum is computed. The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Notes:

Right clicking on the utility window will allow you to copy the contents to the clipboard.


Total Harmonic Distortion

Real world devices introduce unwanted side effects called distortion in addition to the desired response. Total Harmonic Distortion (THD) and (THD+Noise) are two widely used measurements of this quantity. Both measurements are expressed as a percentage. The lower the THD value, the "cleaner" the response.

Total Harmonic Distortion (THD) - the ratio of the harmonic power to the fundamental power. It is computed by searching the entire spectrum to find the peak frequency (fundamental) and then calculating the total power in the harmonic frequencies. The THD level is then computed as the ratio of the total harmonic power to the fundamental power. Residual noise is not included in this calculation.

Total Harmonic Distortion + Noise (THD+N) - the ratio of the harmonic power plus noise to the fundamental power. It is computed by searching the entire spectrum to find the peak frequency (fundamental) and then calculating the total power in the remaining spectrum (harmonics plus noise). The THD level is then computed as the ratio of the total harmonic+noise power to the fundamental power.

THD+N values will almost always be greater than the THD values for the same signal.

A typical THD measurement will use a 1kHz reference test tone. This reference signal is passed through the device under test and its spectrum computed. It is often useful to employ long term averaging to cancel the random noise components and enhance the measurement accuracy.

It should be noted that the purity of both the D/A channel must exceed the device being measured if meaningful results are to be expected.

This utility window can be resized as required by the user and its contents will update anytime a new spectrum is computed. The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Right clicking on the utility window will allow you to copy the contents to the clipboard.

Notes:

  • Hanning or Blackman smoothing window is recommended because of its low noise quality.
  • An FFT size of 2048 or greater is recommended in order to to provide adequate spectral resolution.

See Also: Measurement Accuracy , THD+N vs Frequency


THD+N vs Frequency

The THD+N versus Frequency utility will generate a stepped frequency signal using the selected output device and compute and display a THD+N vs Frequency plot. This utility allows you to quickly and conveniently measure the distortion characteristics of your device over a range of frequencies.

To start the utility click on the <Utilities><THD+N vs Frequency> menu or click on the "THD Freq" button on the toolbar. The utility will produce a stepped frequency sweep which provides the stimulus for the measurement. It must be connected from the selected D/A channel (see Output Device Settings ) to the device under test (DUT). The output of the device is then connected to the analog input channel. During the test, no operator intervention is required. The computer performs all the ncessary steps and plots the results across the band.

Once the results have been analyzed, the plot can be ploted, printed and stored to disk. Right clicking on the plot will also popup a menu of options allowing you to place the data or plot image on the clipboard for use in other applications.

Options

The THD+N vs Frequency options dialog box can be activated by clicking on the "Options" button along the right side of the plot area. This dialog box allows you to change the frequency span, display color scheme and a number of other useful options:

Start and Stop Frequencies - this sets the frequency limits of the measurement. The stop frequency must be less than 1/2 of the current sampling rate used on the main analyzer settings.

Channels - up to two channels can be analyzed.

THD Type - Choose the distortion measurement type (THD or THD+Noise)

Frequency Step size - select a specific linear step size in Hz or octave scaling (1/1 thru 1/96). The stepped sine takes between 1 and 2 seconds per frequency step - decreasing the step size will increase the time required to perform the test.

Spectral Weighting - sets the spectral weighting used for the computations.

Plot Top - this sets the uppermost point for the amplitude axis. The value is entered as a percentage.

Plot Bottom - this sets the lowermost point for the amplitude axis. The value is entered as a percentage.

Frequency Axis Scaling - this sets the scaling format for the frequency axis.

Amplitude Axis Scaling - this sets the amplitude axis scaling format.

Test Limits - this lets you specify a file containing limits for each channel. The limit data will show as a separate trace. The limit file format is the same as the overlay and mic files and is a simple ASCII text file with two tab delimited columns of numbers; the first column contains the frequency and the second column contains the THD limit. The values must be in increasing order by frequency.

Prompt to Save - controls whether or not you will be prompted to save the data before starting a new test.

Notes:

a) You must use the internally generated stepped frequency signal as the source.

b) The only main analyzer settings that are used for this utility are as follows:

  • Device selection
  • Sampling Rate
  • Sampling Precision


InterModulation Distortion (IMD)

InterModulation Distortion (IMD) is a measure of the distortion caused by the interaction (mixing) of two tones.

When multiple signals are injected into a device, undesired modulation or mixing of these two signals can occur. The IMD level is calculated by first computing the frequencies and amplitudes of the two strongest tones in the spectrum. The total power in each of the intermodulation product frequencies is then computed. IMD is the ratio of the intermodulation power to the rms sum of the tone power.

A typical IMD measurement will use tones at 250 Hz and 8020 Hz with the higher frequency tone reduced by 12dB (4:1 ratio) below the low frequency tone. It is often useful to employ long term averaging to cancel the random noise components and enhance the measurement accuracy.

This utility window can be resized as required by the user and its contents will update anytime a new spectrum is computed. The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Right clicking on the utility window will allow you to copy the contents to the clipboard.

Notes:

  • Hanning or Blackman smoothing window is recommended because of its low noise quality.
  • An FFT size of 4096 or greater is recommended in order to to provide adequate spectral resolution for the IMD measurements

See Also: IMD test tones


Signal to Noise Ratio (SNR)

The Signal to Noise Ratio (SNR) is the ratio of the signal peak power level to the total noise level and is expressed in decibels (dB).

The SNR is computed by searching the entire spectrum to find the peak frequency and then calculating the total noise power in the remaining spectrum. The SNR is then computed as the ratio of the noise power to the peak power and expressed in decibels.

This utility window can be resized as required by the user and its contents will update anytime a new spectrum is computed. The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Right clicking on the utility window will allow you to copy the contents to the clipboard.

Notes:

  • Hanning or Blackman smoothing window is recommended because of its low noise quality.
  • An FFT size of 2048 or greater is recommended in order to to provide adequate spectral resolution.

See Also: SINAD


Signal to Noise and Distortion (SINAD)

SINAD is a common sensitivity measurement normally associated with FM receivers. It is an acronym for Signal plus noise and distortion and is equal to (S+N)/N in our system. It is expressed in dB. If the signal is much stronger than the noise then SINAD value approaches the SNR value. Otherwise SINAD will be greater than the SNR.

This utility window can be resized as required by the user and its contents will update anytime a new spectrum is computed. The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Right clicking on the utility window will allow you to copy the contents to the clipboard.

Notes:

  • Hanning or Blackman smoothing window is recommended because of its low noise quality.
  • An FFT size of 2048 or greater is recommended in order to to provide adequate spectral resolution.

See Also: SNR


Reverberation Time

Reverberation Time (RT-60)

Reverberation Time

The Reverberation Time utility allows you to measure and analyze the reverberation decay time and spectral characteristics of an acoustic environment. Reverberation is the sound you hear after an initial burst of energy. This measurement, called RT-60 is a standard method of characterization for concert halls and auditoriums and is the time it takes the sound to decay to 60 dB below its original level.

The Reverberation utility includes an internal pink noise generator which provides the stimulus for the RT-60 measurement. It must be connected from the D/A output channel (see Output Device Settings ) through a power amplifier to a high-quality loudspeaker in the room. Typically only one loudspeaker is used for the test (rather than an array of speakers). The amplifier output level should be adjusted so that it is loud enough to "saturate" the environment because the louder the initial sound, the more accurate the resulting RT-60 curves; however, the level should not be so high as to clip the power amplifier or produce distortion from the loudspeakers.

During the test, no operator intervention is required. The computer performs all the ncessary steps to produce a family of decay curves across the audio band. First it activates the noise source long enough to saturate the environment (that is, an equilibrium is reached between direct and reverberant sound throughout the room). Then the sound is turned off and the decay of the signal captured and the reverberation response analyzed in detail.

To use an signal source other than the internal pink noise such as a ballon pop or gunshot follow the steps below:

1) Use the Recorder mode to capture the signal and subsequent decay.

2) Examine the waveform using the Time Series plot and graphically select the signal and the decay; to do this click the selection arrow and then click and drag the mouse across a range of time. When the mouse button is released, the selected time segment will be shown with inverse video.

3) Right click on the plot and select the "Compute and Display RT-60" menu item.

4) The Reverb Time utility will open and the results computed and displayed.

5) You can fine tune the time at which the utility will start the decay time calculation by changing the value in the Start Offset control on the toolbar or by right clicking on the decay plot at the desired time offset and selecting the "Set Decay Start Time" menu. This will recompute the results based on the new decay start point. The offset can also be set in the reverberation options dialog box.

Once the reverberation signal has been captured and analyzed, a series of plots can be ploted, printed and stored to disk. Right clicking on the plot will also popup a menu of options allowing you to place the data or plot image on the clipboard for use in other applications.

Reverberation Plots

Reverb Times - this is a bar graph of reverberation time versus frequency band. 1/3 Octave bands from 80 Hz to 20 kHz are available. In addition a "wideband" or broadband value is shown on the right side. The analyzer defaults to displaying the RT-60 decay time; however, you can change this to display the decay time for RT-10 through RT-60 by using the associated control on the toolbar. In addition double clicking on one of the bars will show the Reverberation Decay plot for the selected frequency band.

Reverb Decay - this is a graph of the reverberation decay versus time for a specific frequency band. You can change the selected frequency band using the associated control on the toolbar and you can change the displayed time limit by using the associated control on the toolbar; this allows you to zoom in to plot the early decay time for instance.

3-D Surface - this is a 3 dimensional surface plot of the reverberation decay; it shows the reverberation response for all frequencies in a single plot. Double clicking on the plot will display the decay plot for that particular band. You can also adjust the displayed time limit by using the associated control on the toolbar.

Reverberation Options

The reverberation options dialog box can be activated by clicking on the "Options" button along the right side of the plot area. This dialog box allows you to can change the color scheme used for the various plots as well as a number of other useful options:

Plot Top - this sets the uppermost point for the amplitude axis in both the Reverb Decay Plot and the 3-D Surface Plot.

Plot Range - this sets the overall range for the amplitude axis in both the Reverb Decay Plot and the 3-D Surface Plot.

Frequency Resolution: You can select either 1/1 Octave of 1/3 Octave.

Maximum Decay Time - this controls how long the analyzer will "listen" for the reverberation decay signal. This value should be set so that it is greater than the maximum expected decay time (you can always zoom in to display a shorter time period). Setting it to a longer time than necessary will not cause a problem but will require additional processing time and also increase the reverb file size. This value defaults to 4 seconds.

Decay Start Time Offset - this allows you to make small adjustments to the initial start point for the decay calculation. Some technicians prefer to ignore the first 100 milliseconds or so of the initial decay. This value can be set directly using the associated toolbar control, in the reverb options dialog box, or by right clicking on one of the Decay plots at the desired time offset and selecting the menu command "Set Decay Start Time". If the offset is non zero you can right click at anytime and select "Clear Decay Start Time Offset" to reset the offset back to zero.

Clear offset when test is run or file is loaded - automatically sets the decay start time delay to zero whenever a new test is run or existing reverb file is loaded.

Extrapolation Method - in a typical acoustic test, it is rare that the difference between the pink noise level and the ambient background level is 60dB or more and because of this we must extrapolate the actual RT-60 time from the earlier decay times. This allows you to change the extrapolation method between RT-10, RT-20, and RT-30. RT-20 is the default setting. If you change this setting, the reverb times will be recomputed and the Reverb Time plot updated.

Smoothing Method - because of the complex nature of reverberation, the response often contains both diffuse reverberation as well as strong reflection components from hard surfaces. The resulting decay plot may appear quite irregular and it is useful to employ smoothing techniques to achieve a better estimation of the reverberation time. You can disable smoothing by choosing "None" or choose between "Average" and "Schroeder". The Average method is a 100 msec moving window that is applied to the decay data. The Schroeder method applies a reverse integration to the decay data starting at the RT-60 time and working backwards in time. The analyzer defaults to using the Average method. If you change this setting, the decay data will be recomputed and the displays will be updated.

Typical Reverberation Times - the following plot shows the typical RT-60 times for various environments.

Notes:

The reverberation data is "normalized" so that the actual starting amplitudes are all adjusted to 0 dB. You may find that if you do not have sufficient signal amplitiude at certain frequencies, the decay curve for these frequencies will appear almost as a flat line with little or no decay.

The analysis method used in this utility has a 10 millisecond resolution. This resolution is not affected by the maximum decay time parameter or any other setting.

See Also: Right Click Action Menus


Equivalent Noise Levels

The Leq analysis window calculates the Leq values as the analyzer runs.

Leq(t) - the equivalent noise level converted to the user specified "reference time period". For example, selecting a 3.6 second time segment of 90 dBA noise and specifying a reference time period of 1 hr (3600 sec) produces an equivalent noise level of 60 dBA.

Leq - the equivalent noise level for the selected time segment.

Lsel - the equivalent noise level converted to a 1 second period.

Lpk - the peak level for the selected time segment. No averaging is used for this parameter.

Lmax - the maximum level for the selected data.

Lmin - the minimum level for the selected data.

L10 - the level exceeded 10% of the time.

L50 - the level exceeded 50% of the time.

L90 - the level exceeded 90% of the time.

Click the "Options" button to set the options for these calculations. You can select the averaging and weighting as needed.

Calculation Interval: determines the time period for recomputing the noise values.

Specific Intervals: Leq values will be recalculated at the specified interval

When the Analyzer Stops: Leq values will only be recalculated when the analyzer "Stop" button is pressed. All data contributes to the Leq values from when the analyzer starts to when it stops. (no values will be available until the analyzer stops).

Channel: Each channel can have different Leq settings. Use the "Copy settings to all channels" to synchronize the settings for all channels.

Notes:

The Leq and LeqT values match if the same time sample is used (as well as averaging and weighting). The LeqT reference time period is set directly in the Leq options dialog box. The Leq time period equals the time period from when you press the analyzer's Run button to when you press the Stop button. For example if you set the LeqT reference time to 60 seconds and run the analyzer in the realtime mode for 60 seconds the Leq and LeqT values will be the same (or very close). The calculation interval allows you to set the time at which the values are calculated and displayed but does not change the Leq time period itself. As in the above example if you set the calculation interval to 4 seconds you will see the LeqT and Leq values slowly converge as you reach 60 seconds.

The current Calibration settings and Transducer Compensation settings (if enabled) are used for these calculations.

See Also: Averaging Types ,


Sound Power Level

Determines the sound power level of a piece of machinery or equipment. Multiple microphones are used and the time averaged sound pressure level at each microphone position are computed. The average SPL of all microphones are integrated and converted to sound power based on the surface area of the test (see ISO-3744/3746 for details). The sound power level is corrected to account for background and environmental noise.

The Sound Power is expressed in dB and is A weighted.

Setup:

Connect each microphones to an analog input channel and calibrate to units of SPL.

Set the same FFT size for all microphone channels.

Define a Composite channel and select the "Average Multiple Channels" measurement type and check the input microphone channels to be included in the average.

Enable any plots to be shown.

Click the <Utilities><Sound Power Level> menu to open the sound power utility.

Run the analyzer. Be sure to use Infinite averaging .

The Sound Power will be calculated and displayed.

This utility will work in all Modes including post processing.

Options:

Click the Options button on the utility to set the test surface area and correction factors.

Notes: The measurement utility will automatically apply A weighting regardless of the value in the scaling dialog box.


Licensing

This software is copy protected using one of the following methods:

  • A "Software Key" contained on the hard drive
  • A "Hardware Key" which is plugged into the computer's USB or Parallel Port
  • A "Network Hardware Key" which is plugged into this or another computer on the network

You can examine the license status at any time by selecting the <License><Status and Authorization> menu command. A list of all available options and their current license status will be displayed. The program defaults to using the Software Key method; Hardware Keys can be purchased as a option for users who need to frequently transfer the license between computers or who simply prefer having a tangible physical key.

Software Key Method

This method uses a "Site Code" and "Authorization Key" technique which restricts the operation to a specific computer. No Hardware Key is required.

The "Site Code" is a number which is unique to your computer and is used to generate the matching "Authorization Key" to enable program operation. Because the Site Code is computer specific, we cannot provide you the corresponding Authorization Key until you send us your Site Code. This Site Code is easily obtained by selecting the <License><Status and Authorization> menu command clicking the "Authorize" button.

Click the "Authorize" button to display the "Site Code" unique to your computer. Click the "Print Site Code" button to print a page containing the site code which you can fax to your software vendor. When you receive your authorization key, return to this dialog box and enter the key. Please note that the Site Code will not change when you exit the program.

Adding additional options to the Software Key

Additional product options can be added to the Software Key in the field. Contact your software vendor to purchase the options or upgrade and provide them with the current "Site Code"; you will then be given a new "Authorization Key". Go to the <License><Status & Authorization> menu and click the "Authorize" button and enter the Authorization Key; this will update the Software Key license information with the new options..

Transferring the Software Key to another computer

To transfer the Software Key, Go to the <License><Status & Authorization> menu and click the "Transfer Key" button and follow the instructions. There are two basic transfer methods: 1) directly over a local network connection, and 2) using a floppy diskette or a USB memory stick. Both methods require that you first install a copy of SpectraPLUS-DT on the computer to which will be receiving the license. Please note that method 2) requires that the floppy disk or USB memory stick first be "registered" using the UNLICENSED copy of SpectraPLUS-DT. After registering the Software Key can be transferred "Out" using the LICENSED copy of SpectraPLUS-DT and then transferred "In" using the UNLICENSED copy.

Because transferring the Software Key requires access to both computers involved in the transfer this is not always a practical solution. If you regularly transfer the license between computers, or if the computers are at different geographical locations, a Hardware Key may offer greater convenience. Please contact your software vendor to obtain a Hardware Key.

Hardware Key Method

This method uses a physical hardware device also known as a "dongle". This hardware key is delivered with the software and is preprogrammed with the options you have purchased.

  • The Hardware Key can be either a USB or Parallel port type.
  • You must install the Hardware Key device driver before the program will detect the key.
  • The Hardware Key device driver is provided on the installation CD-ROM. You must login as administrator when installing the driver; once installed you can login using your normal user account.

Adding additional options to the Hardware Key

Additional product options can be added to the Hardware Key in the field. Contact your software vendor to purchase the options or upgrade; you will then be given a "Field Activation Key". Go to the <License><Status & Authorization> menu and click the "Authorize" button and enter the Activation Key; this will update the Hardware Key license information with the new options..

Network Hardware Key Method

This method also uses a USB or Parallel Port hardware key device but contains the ability to manage multiple licenses over the network. The Network Hardware Key allows multiple users to be running the software simultaneously and only one Network Hardware Key is required. The Key is preprogrammed with a user limit that, once reached, will not allow additional copies to run until other copies are shutdown. If a machine running SpectraPLUS-DT crashes or is detached from the network, it will not have a chance to release its license; however, the license server will automatically release the license if communications are lost for more than about 5 minutes or so.

The Network Hardware Key can be installed on any machine on the local network but requires the installation of a "License Server" device driver. This "License Server" component is provided with the Network Key and only needs to be installed on the machine containing the Network Hardware Key. All other machines that will be running SpectraPLUS-DT only need to have the normal Hardware Key device driver installed.

  • The SpectraPLUS-DT software must be installed on each local machine
  • The standard Hardware Key driver must be installed on each local machine
  • One of the machines in the network must have the Network Hardware Key installed and is designated the "license server".
  • The "license server" does not have to be a true "server" but can simply be one of the computers in a peer to peer network.
  • The "license server" hardware key device driver must be installed on the machine with the Network Hardware Key.

Additional network options allow you to specify a specific server and protocol but in most cases selecting the option labelled "Automatically find the license server on the network" should be used.

A Monitoring Tool is provided with the License Server to allow the administrator to check the number of copies in use.


Data Logging

Data logging allows you to produce output text files containing selected spectral parameters along with a timestamp showing when the event occurred. A separate file is written for each enabled channel.

File Options

Enable Logging: controls the overall logging status.

Filename Format: selects the filename format to use for each channel.

Overwrite Existing file: if a file with the same name already exists it will be overwritten/

Append to Existing file: if a file with the same name already exists, new data will be apended.

Include Time Stamp in first column: if selected, a time stamp will be written for each line in the log file

Include Header on first row: if selected, a descriptive header row will be written on the first line of the file.

Viewer Program: Select the name of the text editor you wish to use for viewing the data logging output files. The output data is always written in ASCII text. Notepad is the default.

Logging options for each channel

Output Data Type: Check one or more of the the data items you want to write to the log file.

Logging Interval: Determines how often the spectral data is logged to the output file.

As Often As Possible - write the parameters to the data logging file every FFT update. The update interval depends on the FFT size and other processing settings.

Specific Intervals - write the parameters to the data logging file at the selected interval.

Reset Spectral Average each interval - resets the spectal averaging after writing the parameters to the logging file. This is useful for logging the average spectral data for just the specified interval. For example: set the spectral average size to Infinite and the interval to 1 second - it will log the one second average and then reset the average for the next interval.

Reset Peak Hold each interval - resets the peak hold spectrum after writing the parameters to the logging file. This is useful for logging the Peak Hold spectral data for just the specified interval. For example: set the Peak Hold value to Forever and the interval to 1 second - the data logging will contain the peak spectral values for the one second interval. It will then reset the Peak Hold for the next interval.

Threshold Conditions - allow you to only output data if a condition has exceeded a threshold. For example: log the vibrational frequency and level if the specified level is exceeded. Time stamp data will also show the times at which the level was exceeded.

Apply - check this box to enable threshold condition testing

Threshold Level - enter the level at which the parameter must exceed before logging will occur. Use the units corresponding to the calibration and amplitude scaling for the channel.

Threshold Type - select the specific parameter that will be tested against the threshold level. Logging will only occur if the value exceeds the specificed threshold level.

Set Markers - allows you to quickly set the marker frequencies used for some of the data logging parameters

Copy these settings to all channels - quickly apply the current selections to other channels

View Output File: Opens the current data log file using the specified viewer program.

View Data Logging Folder: Opens the data log folder using Explorer so you can manage your data log files. The default folder is set in the <File><Set Paths> menu.

Notes: Use caution when logging the entire spectrum values for large frequency ranges. The resulting data file will be very large. Use the Marked Spectrum option to limit the frequency range.

Data Logging On: Fri Sep 30 10:43:41 2009

Time Freq(Hz) Amplitude(dB)

--------------------------------------------------------------

10:43:41 527.56 -45.60

10:43:42 495.26 -54.03

10:43:43 495.26 -49.83

10:43:44 1399.66 -59.01

10:43:48 1399.66 -59.14

10:43:49 516.80 -56.38

10:43:50 549.10 -53.37

10:43:51 624.46 -43.66

10:43:52 559.86 -37.96


COM API

The analyzer can be controlled and results read from an external program such as Visual Basic, C++ or Excel.

Initializing the Interface

Control Functions

Read Data Functions

Visit our website to download sample projects.


COM API - Initialization

Using Visual Basic

Using Visual C++

Excel

Note: If the Automation Tools option (/10) is not licensed you will get an "Accessed Denied" message when you try to create an instance of the class.

Visual Basic (Microsoft Visual Studio 2008)

1. Add a reference to the automation interface to your project

2. Create an instance of the class

3. Call the methods

Add the reference to your project:

1. Choose Project | Add Reference…

2. On the Add Reference dialog, choose the COM tab

3. Select the SpectraPLUS-DT Automation Typelib

4. Click OK

Dimension and Instantiate an instance of the SpectraPLUS DT Automation Interface class object

Dim SP As SpectraPLUS_DTAutomationLib.ISpectraPLUS_DT

SP = New SpectraPLUS_DTAutomationLib.SpectraPLUS_DTClass

Call the methods in the interface as desired

SP.Run()

Return Values

The methods return HRESULTs, so Visual Basic will convert the return value to an exception if an error occurred. As such, you must handle exceptions in your code.

On Error GoTo Err_Trap

... call methods, etc.

Err_Trap:

Dim sMsg As String

sMsg = "The error returned: "

sMsg = sMsg & Err.Description

MsgBox sMsg, vbCritical, _

"Error" & Str$(Err.Number)

Err.Clear

Resume Next

Accessing Arrays

Below is a simple example of how to use the SAFEARRAYS with the GetSpectrum() call. Both freq and data are single precision floating point arrays.

Dim freq() As Single

Dim data() As Single

SP.GetSpectrum(0, freq, data)

Dim n As Variant

For Each n In freq

Value = n

Next n

For Each q In data

Value = q

Next q

Visual C++ (Visual Studio 2008)

1. Import the Type Library (TLB)

2. Create a smart pointer of that type

3. Call the methods

#import "C:\Program Files\SpectraPLUS_DT\bin\ SPDTAxnIface.tlb" no_namespace

CoInitialize(NULL);

ISpectraPLUS_DTPtr ISP(__uuidof(SpectraPLUS_DTClass));

if ( ISP )

{

ISP->Run();

}

… execute remainder of program …

ISP = 0;

The return values of the functions are HRESULTS. The Visual C++ implementation of smart pointers will intercept those return values and throw exceptions on errors. Thus, all code must be wrapped with try/catch blocks. The type of exception thrown is an _com_error.

try

{

ISP->Run();

}

catch ( _com_error &error )

{

MessageBox( error.ErrorMessage() );

}

Microsoft Excel

1. Enable the Developer tab in Excel

2. Add a reference to the automation interface

3. Create an instance of the class

4. Call the methods

Enable the Developer tab

Excel 2007

1. Click on the Office button

2. Click on Excel Options

3. Click Popular

4. Check the "Show Developer tab in the Ribbon" box

Excel 2010

1. Click on the File tab

2. Click the Options command

3. Click the Customize Ribbon category

4. In the Main Tabs list on the right, put a check in the "Developer" box

Add a reference to the automation interface

1. Click on the Developer tab

2. Click on View Code

3. Choose Tools | References

4. Scroll down and check the box next to the "SpectraPLUS-DT Automation Typelib"

5. Click OK

Dimension and Instantiate an instance of the SpectraPLUS-DT Automation Interface class object

Dim SP As SpectraPLUS_DTClass

Set SP = CreateObject("SpectraPLUS_DT.Axn")

Call the methods

SP.Run

Below is a simple example of how to read an array of spectral data and write it to the spreadsheet

Dim channel As Integer

Dim startHz As Single

Dim stopHz As Single

' define the frequency span and channel

channel = 0

startHz = 500#

stopHz = 2000#

' Arrays to contain the spectral data

Dim freq() As Single

Dim data() As Single

' Read the data from the analyzer

SP.GetSpectrumInSpan channel, startHz, stopHz, freq, data

Dim n As Variant

Dim q As Variant

Dim col As Integer

Dim row As Integer

' Load the data into the cells

col = 1

row = 1

For Each n In freq

Sheet1.Cells(row, col).value = n

row = row + 1

Next n

col = 2

row = 1

For Each q In data

Sheet1.Cells(row, col).value = q

row = row + 1

Next q


COM API - Control Functions

The following functions can be used to control the analzyer.

Function Groups

Analyzer Operations

Analyzer Configuration

Plot and Window Commands

Overlay Control

File Management

File Positioning

File Post Processing

Signal Generation

Digital Input and Output Lines

Analyzer Operations

Run()

Description: Run the analyzer or start recording

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

Stop()

Description: Stop the analyzer or recording

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

Record()

Description: Start recording

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

RecordPause()

Description: Pause the current recording. The analyzer will continue running but data will not be stored in the wave file.

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

RecordResume()

Description: Resume a paused recording.

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

Fil eStep( int numFFTSteps )

Description: Performs the specified number of FFTs starting at the current file position and advancing by the overlap setting (Post Processing mode only)

Parameters: numFFTSteps: 1 or more

Return: S_OK = success, E_FAIL = unsuccessful

Trigger()

Description: Forces a single trigger event. Analyzer must be running and triggering must be enabled.

Return: S_OK = success, E_FAIL = unsuccessful

Analyzer Configuration

LoadConfig( BSTR cfg_filename )

Description: Load the specified configuration file. This is the quickest way to change all the analyzer settings.

Parameters: cfg_filename = filename of the configuration file. Full path or just filename if file located in /Config folder

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will look in the Config path as listed in the <File><Set Paths> dialog box.

SaveConfig( BSTR cfg_filename )

Description: Save the current settings to the specified configuration file

Parameters: cfg_filename = filename of the configuration file.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will store in the Config path as listed in the <File><Set Paths> dialog box.

SetMode( long mode )

Description: Set the current mode

Parameters: mode: 0 = Real Time, 1 = Recorder, 2 = Post Processing

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ChannelEnable( long channel )

Description: Enable the specified channel

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ChannelDisable( long channel )

Description: Disable the specified channel

Parameters: channel = 0 - 15

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

RecordEnable( long channel )

Description: Enable recording for the specified channel (device channel must also be enabled - use ChannelEnable())

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

RecordDisable( long channel )

Description: Disable recording for the specified channel

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSamplingRate( long rate )

Description: Set the sampling rate for the device

Parameters: rate = samples per second (applies to all channels)

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSamplingPrecision( long bits )

Description: Set the sampling precision for the device

Parameters: bits = bits per sample (applies to all channels)

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetFFTsize( long channel, long fft_size )

Description: Set the FFT size for the specified channel

Parameters: channel = 0 - 16, fft_size = 32 through 1048576 pts

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSmoothingWindow( long channel, long window )

Description: Set the Smoothing window for the specified channel

Parameters: channel = 0 - 16, window = values as shown below:

      BARTLETT       0

      BLACKMAN       1

      EXPONENTIAL    2

      FLATTOP        3

      FORCE          4

      HAMMING        5

      HANNING        6

      KAISER         7

      PARZEN         8

      TRIANGULAR     9

      UNIFORM        10

      GAUSSIAN       11

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetAverageMode( long channel, long mode )

Description: Set the Averaging Mode for the specified channel

Parameters: channel = 0 - 16, mode: 0 = Free Run, 1 = Sound Level Meter

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetAverageType( long channel, long type )

Description: Set the Averaging Type for the specified channel

Parameters: channel = 0 - 16, type: 0 = Exponential, 1 = Linear, 2 = Vector

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

EnablePSD( long channel )

Description: Enable Power Spectral Density scaling

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful

DisablePSD( long channel )

Description: Disable Power Spectral Density scaling

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful

SetAmplitudeScaleType( long channel, long scale_type )

Description: Set the amplitude axis scaling type for the specified channel

Parameters: channel = 0 - 16, scale_type: 0 = Linear, 1 = Logarithmic, 2 = Log Magnitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetFrequencyScaleType( long channel, long scale_type, long octave_number )

Description: Set the frequency axis scaling type for the specified channel

Parameters: channel = 0 - 16, scale_type: 0 = Linear, 1 = Logarithmic, 2 = Octave.

octave_number: 1,3,6,9,12,24,48,96 (ignored if scale_type not Octave)

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSpectrumWeighting( long channel, long weighting )

Description: Set the spectrum weighting for the specified channel

Parameters: channel = 0 - 16, weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetTotalPowerWeighting( long channel, long weighting )

Description: Set the total power weighting for the specified channel

Parameters: channel = 0 - 16, weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

TriggerEnable()

Description: Enable triggering

Return: S_OK = success, E_FAIL = unsuccessful

TriggerDisable()

Description: Disable triggering

Return: S_OK = success, E_FAIL = unsuccessful

SetTriggerThreshold( float threshold_volts )

Description: Set the trigger threshold

Parameters: the trigger threshold in volts. Must be between 0 and 10.0

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetAverageSiz e( long channel, long size)

Description: Set the average size for the specified channel

Parameters: channel = 0 - 16; size = average size 1 - 10000 (free run mode), 0 = Off, 1 = Fast, 2 = Medium, 3 = Slow, 4 = Forever (SLM mode)

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ResetAverag e( long channel)

Description: Reset the running average for the specified channel

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetPeakHold( long channel_ext, long peak_hold_type )

Description: Set the peak hold type for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

peak_hold_type: 0 = Off, 1 = Fast, 2 = Medium, 3 = Slow, 4 = Forever

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ResetPeakHold( long channel_ext )

Description: Resets the peak hold values for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetOverlapPercentage( long channel, long overlap_percent )

Description: Sets the overlap percentage value for the specified channel

Parameters: channel = 0 - 16; overlap_percent = 1 - 99

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetCompensationFile( long channel, BSTR short_filename )

Description: Set the transducer compensation file for the specified channel

Parameters: channel = 0 - 16, short_filename: short filename (same as shown in the scaling dialog box). Use "None" to disable compensation.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetMarkerFreq( long channel_ext, long marker, float freqHz )

Description: Set the frequency for the specific channel and marker index

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

marker = 1 - 8, freqHz = frequency in Hz

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ResetOverloadCount( )

Description: Reset the overload (clipping) count for all channels

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

DataLoggingEnable()

Description: Enable data logging

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

DataLoggingDisable()

Description: Disable data logging

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

LoadCalibrationFile( long channel, BSTR short_filename )

Description: Load the calibration file for the specified channel

Parameters: channel = 0 - 16; short_filename = the short filename of the calibration file (same as shown in the calibration dialog box). Use "Volts", "Millivolts" or "RPM" for the internally supported units.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

CalibrateToExternalSource( long channel, float source_level )

Description: Perform a calibration measurement on the specified channel

Parameters: channel = 0 - 16; source_level = value to calibrate to (SPL example: 94.0).

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Notes:

You must be using the calibration option to calibrate to an external source.

The measurement will continue until the following conditions are met:

1) The measured signal level is stable to within +/-0.1 millivolt. This is approximately +/-0.03 dB with typical mic sensitivities.

2) The measured signal level is within 12% of its original value. This is approximately +/-1 dB.

If both of these conditions are not satisfied within 60 seconds the measurement will stop and an E_FAIL error will occur.

These conditions will assure that settling has completed, the mic calibrator is turned on and the correct mic and channel are used.

SaveCalibrationFile( long channel, BSTR cal_filename )

Description: Save the calibration file for the specified channel

Parameters: channel = 0 - 16; cal_filename = filename of the calibration file.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will store in the Cal path as listed in the <File><Set Paths> dialog box.

SetChannelName( long channel, BSTR name )

Description: Set the channel name for the specified channel

Parameters: channel = 0 - 16; name = string to use as the channel name.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetRunControl( long mode, long fft_limit, float time_limit, float start_delay_time )

Description: Set the Run Control options

Parameters: mode: 0=Continuous, 1=Stop after FFT limit, 2=Stop after time limit

fft_limit: number of FFTs to process before stopping when mode = 1

time_limit: seconds to process before stopping when mode = 2

start_delay_time: seconds to delay before starting processor

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetMetadata( long channel, BSTR metadata )

Description: Set the metadata text to store in the current wafe file. Wave file must be open for this function to suceed.

Parameters: channel = 0 - 16; metadata - up to 2000 characters max of ascii text

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Plot and Window Commands

OpenPlot( long channel_ext, long plot_type )

Description: Opens a plot for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

plot_type: 1 = Time Series, 2 = Spectrum, 3 = Phase, 4 = Spectrogram, 5 = 3-D Surface

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ClosePlot( long channel_ext, long plot_type )

Description: Closes a plot for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

plot_type: 1 = Time Series, 2 = Spectrum, 3 = Phase, 4 = Spectrogram, 5 = 3-D Surface

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

MinimizeApplication( )

Description: Minimize the overall application window to an icon

Return: S_OK = success, E_FAIL = unsuccessful

MaximizeApplication( )

Description: Maximize the overall application window on the screen

Return: S_OK = success, E_FAIL = unsuccessful

RestoreApplication( )

Description: Restore the application to it's previous size

Return: S_OK = success, E_FAIL = unsuccessful

HideApplication( )

Description: Hide the overall application window and icon.

Return: S_OK = success, E_FAIL = unsuccessful

ShowApplication( )

Description: Show the overall application window and icon (restore from HideApplication())

Return: S_OK = success, E_FAIL = unsuccessful

ClearSpectrum( long channel_ext )

Description: Clears the spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ClearPeakHoldSpectrum( long channel_ext )

Description: Clears the peak hold spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSpectrumPlotFrequencySpan( long channel_ext, float startHz, float stopHz )

Description: Set the displayed frequency span for the spectrum plot for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

startHz = start frequency, stopHz = stop frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSpectrumPlotTop( long channel_ext, float plot_top )

Description: Set the display amplitude plot top parameter for the spectrum plot for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels; plot_top = plot top value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSpectrumPlotRange( long channel_ext, float plot_range )

Description: Set the display amplitude plot range parameter for the spectrum plot for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels; plot_range = plot range value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetSpectrumPlotGraphType( long channel_ext, long graph_type )

Description: Set the spectrum plot graph type for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

graph_type: 0 = Line, 1= Bars, 2 = Stepped Bars

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetTimeSeriesPlotTimeSpan( long channel, float start_time, float stop_time )

Description: Set the time span to be displayed on the time series plot

Parameters: channel = 0 - 16, start_time, stop_time = time span to display

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

WritePlotToBitmapFile( long channel_ext, long plot_type, BSTR bmp_filename )

Description: Saves the plot image to a bitmap file

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

plot_type: 1 = Time Series, 2 = Spectrum, 3 = Phase, 4 = Spectrogram, 5 = 3-D Surface

bmp_filename = full filename and path to store bitmap

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Overlay Control

SetOverlay( long channel_ext, long overlay_index, int create_from_peak_hold, BSTR szLegend)

Description: Create an overlay from the current spectral data

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

overlay_index = 1 - 7

create_from_peak_hold = 1 to create the overlay from the peak hold values (peak hold must be enabled)

szLegend = legend to apply to overlay

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ShowOverlay( long channel_ext, long overlay_index)

Description: Shows the specified overlay

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

overlay_index = 1 - 7

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

HideOverlay( long channel_ext, long overlay_index)

Description: Hides the specified overlay

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

overlay_index = 1 - 7

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SaveOverlay( long channel_ext, long overlay_index, BSTR ovl_filename)

Description: Save an overlay to a file

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

overlay_index = 1 - 7

ovl_filename = name of the overlay file.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will store in the Overlay path as listed in the <File><Set Paths> dialog box.

LoadOverlay( long channel_ext, long overlay_index, BSTR ovl_filename)

Description: Load an overlay from a file

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

overlay_index = 1 - 7

ovl_filename = name of the overlay file to load

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will load it from the Overlay path as listed in the <File><Set Paths> dialog box.

File Management

FileOpen( long channel, BSTR wav_filename)

Description: Open a wave file on the specified channel.

Parameters: channel = 0 - 16; wav_filename =filename

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will look in the Wave path as listed in the <File><Set Paths> dialog box.

FileSave( long channel, BSTR wav_filename)

Description: Save the wave file on the specified channel.

Parameters: channel = 0 - 16; wav_filename = filename

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: If a short filename is used, it will store in the Wave path as listed in the <File><Set Paths> dialog box.

FileClose( long channel )

Description: Close the wave file on the specified channel

Parameters: channel = 0 - 16

Note: if the channel parameter is set to -1, all open wave files will be closed without saving

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

File Positioning

FileRewind( long channel )

Description: Go to the start of the wave file on the specified channel

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileForward( long channel )

Description: Go to the end of the wave file on the specified channel

Parameters: channel = 0 - 16

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileGoToTime( long channel, float seconds)

Description: Go to a specific time on the specified channel

Parameters: channel = 0 - 16; seconds = file position in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileGoToSample( long channel, unsigned long sample)

Description: Go to a sample position on the specified channel

Parameters: channel = 0 - 16; sample = file position in samples

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

File Post Processing

FilePlaySegment Time( long channel, float start_seconds, float stop_seconds)

Description: Playback the specified time segment for the selected channel

Parameters: channel = 0 - 16; start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FilePlaySegmentSampl e( long channel, unsigned long start_sample, unsigned long stop_sample)

Description: Playback the specified time segment for the selected channel

Parameters: channel = 0 - 16; start_sample = segment start sample position; stop_sample = segment stop sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileFilterSegmentTi me( long channel, float start_seconds, float stop_seconds)

Description: Filter the specified time segment for the selected channel

Parameters: channel = 0 - 16; start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileFilterSegmentSamp le( long channel, unsigned long start_sample, unsigned long stop_sample)

Description: Filter the specified time segment for the selected channel

Parameters: channel = 0 - 16; start_sample = segment start sample position; stop_sample = segment stop sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileProcessSegmentTim e( long channel, float start_seconds, float stop_seconds)

Description: Computes the average spectral data for the specified time segment for the selected channel (same as right clicking on time series plot and choosing "Compute Average Spectrum")

Parameters: channel = 0 - 16; start_seconds = segment start time; stop_seconds = segment stop time.

Note: If the specified time segment is less than a full FFT size, zero padding will be applied

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileProcessSegmentSamp le( long channel, unsigned long start_sample, unsigned long stop_sample)

Description: Computes the average spectral data for the specified time segment for the selected channel (same as right clicking on time series plot and choosing "Compute Average Spectrum")

Parameters: channel = 0 - 16; start_sample = segment start sample position; stop_sample = segment stop sample position

Note: If the specified time segment is less than a full FFT size, zero padding will be applied

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileCutTi me( long channel, float start_seconds, float stop_seconds)

Description: Cut the specified time segment for the selected channel and place it on the clipboard

Parameters: channel = 0 - 16; start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileCutSamples( long channel, long start_sample, long stop_sample)

Description: Cut the specified time segment for the selected channel and place it on the clipboard

Parameters: channel = 0 - 16; start_sample = segment start position; stop_sample = segment stop position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileCopyTi me( long channel, float start_seconds, float stop_seconds)

Description: Copy the specified time segment for the selected channel and place it on the clipboard

Parameters: channel = 0 - 16; start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileCopySamples( long channel, long start_sample, long stop_sample)

Description: Copy the specified time segment for the selected channel and place it on the clipboard

Parameters: channel = 0 - 16; start_sample = segment start position; stop_sample = segment stop position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FilePasteTi me( long channel, float paste_position_seconds)

Description: Paste the current clipboard contents (wave data) into the current file at the specified position

Parameters: channel = 0 - 16; paste_position_seconds = location to paste the data

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FilePasteSamples( long channel, long paste_position_sample)

Description: Paste the current clipboard contents (wave data) into the current file at the specified position

Parameters: channel = 0 - 16; paste_position_sample = location to paste the data

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileMuteTi me( long channel, float start_seconds, float stop_seconds)

Description: Mute the specified time segment for the selected channel

Parameters: channel = 0 - 16; start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileMuteSamples( long channel, long start_sample, long stop_sample)

Description: Mute the specified time segment for the selected channel

Parameters: channel = 0 - 16; start_sample = segment start position; stop_sample = segment stop position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileBuildSpectrogramPlot( long channel_ext, float start_seconds, float stop_seconds)

Description: Computes and displays the Spectrogram plot for the specified time segment for the selected channel (same as right clicking on time series plot and choosing "Compute and Display Spectrogram")

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

FileBuildSurfacePlot( long channel_ext, float start_seconds, float stop_seconds)

Description: Computes and displays the 3-D Surface plot for the specified time segment for the selected channel (same as right clicking on time series plot and choosing "Compute and Display 3-D Surface")

Parameters: channel_ext = 0 - 16 for main channels, 17 -32 for composite channels;

start_seconds = segment start time; stop_seconds = segment stop time

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid paramete

Signal Generation

OpenGenerator()

Description: Open the signal generator utility

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

CloseGenerator()

Description: Close the signal generator utility

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

RunGenerator()

Description: Start the signal generator

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

StopGenerator()

Description: Stop the signal generator

Parameters: none

Return: S_OK = success, E_FAIL = unsuccessful

SetGeneratorSignalType( long channel_sig, long signal_type )

Description: Set the signal type for the specified signal generator channel

Parameters: channel = 0 - 1; signal_type - as follows:

0 = White Noise

1 = Pink Noise

2 = Noise Burst

3 = 1 kHz Tone

4 = Multiple Tones

5 = Tone Burst

6 = IMD Tones

7 = Freq Sweep

8 = Level Sweep

9 = Sawtooth

10 = Triangular

11 = Pulse

12 = Squarewave

13 = User Defined wave file

14 = DTMF

16 = Digital Zero

16 = Frequency Step

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

SetGeneratorLevel( long channel_sig, float volts )

Description: Set the output level for the specified signal generator channel

Parameters: channel = 0 - 1; volts = rms voltage level

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: The output units will change to Volts when this command is used.

SetGeneratorFreq( long channel_sig, float freqHz )

Description: Set the signal type to Multiple tones and enable only a single tone at the specified frequency. The multitone level is set to 0 dBr (use SetGeneratorLeve() to set the output level)

Parameters: channel_sig = 0 - 1; freqHz = frequency in Hz

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: The signal type will change to Multiple Tones when this command is used.

SetGeneratorMultiTone( long channel_sig, long tone_idx, int enable, float freqHz, float levelDBr, float phaseDeg)

Description: Set the signal type to Multiple tones and set the parameters for a specific tone index.

Parameters: channel_sig = 0-1; tone_idx = 0-9, enable = 0 (off) or 1 (on), freqHz = frequency in Hz, levelDBr = relative level of tone in dBr (0.0 to -96), phase in degrees (-180 to +180)

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: The signal type will change to Multiple Tones when this command is used.

LoadGeneratorMultiToneFile( long channel_sig, BSTR toneFilename )

Description: Load a .tones file from disk - this allows you to change the set of tones

Parameters: channel_sig = 0 - 1; toneFilename = name of .tones file

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Note: The signal type will change to Multiple Tones when this command is used.

Digital Input and Output Lines

Many of the Data Translation modules have Digital Input and Output lines for controlling and

reading external equipment such as relays. These functions allow you to read and write the

state of these lines.

GetDigitalInputLineState( DWORD *state )

Description: Get the current state of the digital Input lines

Parameters: state = pointer to value to receive the current state of the digital input lines

Return: S_OK = success, E_FAIL = unsuccessful

SetDigitalOutputLineState( DWORD state )

Description: Set the current state of the digital Output lines

Parameters: state = value containing the new state to set the output lines

Return: S_OK = success, E_FAIL = unsuccessful


COM API - Read Data Functions

Functions used to read data and status from the analyzer:

General Status

Peak Search Operations

Distortion Readings

Total Power Readings

Marker Readings

Conversion Operations

Time Series Data

Spectral Data

Phase Data

Leq Data

Misc

General Status

IsRunning ( int *runStatus )

Description: Determine if the analyzer is currently running, or recording

Parameters: runStatus = pointer to receive the analyzer run status (0 = stopped, 1 = running or recording)

Return: S_OK = success, E_FAIL

GetCurrentFileTime( long channel, float *seconds )

Description: Get the current time in the file for the specified channel

Parameters: channel = 0 - 15; seconds = pointer to variable to receive the time value in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTotalFileTime( long channel, float *seconds )

Description: Get the total time in the file for the specified channel

Parameters: channel = 0 - 15; seconds = pointer to variable to receive the time value in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetCurrentFileSample( long channel, unsigned long *sample )

Description: Get the current sample position in the file for the specified channel

Parameters: channel = 0 - 15; sample =pointer to variable to receive the sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTotalFileSamples( long channel, unsigned long *samples )

Description: Get the total number of samples in the file for the specified channel

Parameters: channel = 0 - 15; samples = pointer to variable to receive the total samples value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetFFTCount( long channel, long *fftcount )

Description: Get the number of FFTs that have been performed since run or record were last pressed

Parameters: channel = 0 - 15; fftcount - pointer to variable to receive the the fft count

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetOverloadCount( long channel, long *overloadcount )

Description: Get the number of Overload conditions (clipping) that have been detected since run or record were last pressed

Parameters: channel = 0 - 15; overloadcount - pointer to variable to receive the the overload count

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Peak Search Operations

GetPeakFrequency( long channel_ext, float *freq )

Description: Get the peak frequency in the total span for the specified channel

Parameters: channel_ext = 0 - 15 for main channels, 17 - 32 for composite channels;

freq = pointer to variable to receive the peak frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakFrequencyNth( long channel_ext, long peak_number, float *freq )

Description: Get the Nth peak frequency in the total span for the specified channel

Parameters: channel_ext = 0 - 15 for main channels, 17 - 32 for composite channels;

peak_number = 0 - 10; freq = pointer to variable to receive the peak frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakFrequencyNthSpan( long channel_ext, long peak_number, float startHz, float stopHz, float *freq )

Description: Get the Nth peak frequency in the specified span for the specified channel

Parameters: channel_ext = 0 - 15 for main channels, 17 - 32 for composite channels;

peak_number = 0 - 10; startHz = span start frequency; stopHz = span stop frequency;

freq = pointer to variable to receive the peak frequency

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakAmplitude( long channel_ext, float *amplitude )

Description: Get the peak amplitude in the total span for the specified channel

Parameters: channel_ext = 0 - 15 for main channels, 17 - 32 for composite channels;

amplitude = pointer to variable to receive the peak amplitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakAmplitudeNth( long channel_ext, long peak_number, float *amplitude )

Description: Get the amplitude of the Nth peak in the total span for the specified channel

Parameters: channel_ext = 0 - 15 for main channels, 17 - 32 for composite channels;

peak_number = 0 - 10; amplitude = pointer to variable to receive the peak amplitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakAmplitudeNthSpan( long channel_ext, long peak_number, float startHz, float stopHz, float *amplitude )

Description: Get the amplitude of the Nth peak in the specified span for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

peak_number = 0 - 10; startHz = span start frequency; stopHz = span stop frequency;

amplitude = pointer to variable to receive the peak amplitude

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Total Power Readings

GetTotalPower( long channel_ext, long weighting, float *power )

Description: Get the total power in the total span for the specified channel and weighting

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

power = pointer to variable to receive the total power value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTotalPowerSpan( long channel_ext, long weighting, float startHz, float stopHz, float *power )

Description: Get the total power for the specified frequency span for the specified channel and weighting

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

weighting: 0 = Flat, 1 = A, 2 = B, 3 = C

startHz = span start frequency; stopHz = span stop frequency;

power = pointer to variable to receive the total power

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Distortion Readings

GetTHD( long channel_ext, float *thd )

Description: Get the THD over the total span for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

thd = pointer to variable to receive the THD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTHDSpan( long channel_ext, float startHz, float stopHz, float *thd )

Description: Get the THD over the specified frequency span and channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = span start frequency; stopHz = span stop frequency;

thd = pointer to variable to receive the THD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTHD_N( long channel_ext, float *thd_n )

Description: Get the THD+N over the total span for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

thd_n = pointer to variable to receive the THD+N value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTHD_NSpan( long channel_ext, float startHz, float stopHz, float *thd_n )

Description: Get the THD+N over the specified frequency span and channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = span start frequency; stopHz = span stop frequency;

thd_n = pointer to variable to receive the THD+N value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetIMD( long channel_ext, float *imd )

Description: Get the IMD over the total span for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

imd = pointer to variable to receive the IMD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSNR( long channel_ext, float *snr )

Description: Get the SNR over the total span for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

snr = pointer to variable to receive the SNR value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSNRSpan( long channel_ext, float startHz, float stopHz, float *snr )

Description: Get the SNR over the specified frequency span and channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = span start frequency; stopHz = span stop frequency;

snr = pointer to variable to receive the SNR value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSINAD( long channel_ext, float *sinad )

Description: Get the SINAD over the total span for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

sinad = pointer to variable to receive the SINAD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSINADSpan( long channel_ext, float startHz, float stopHz, float *sinad )

Description: Get the SINAD over the specified frequency span and channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = span start frequency; stopHz = span stop frequency;

sinad = pointer to variable to receive the SINAD value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Marker Readings

GetMarkerFrequency( long channel_ext, long marker, float *freq )

Description: Get the frequency at the specified marker

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

marker = 1 - 8;

freq = pointer to variable to receive the frequency value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetMarkerAmplitude( long channel_ext, long marker, float *amplitude )

Description: Get the amplitude at the specified marker

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

marker = 1 - 8;

amplitude = pointer to variable to receive the amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Conversion Operations

ConvertTimeToSample( long channel, float time_seconds, unsigned long *sample )

Description: Convert from seconds to sample position for the specified channel

Parameters: channel_ext = 0 - 16; time_seconds = time value to convert

sample = pointer to variable to receive the sample position

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

ConvertSampleToTime( long channel, unsigned long sample, float *time_seconds )

Description: Convert from sample position to time for the specified channel

Parameters: channel_ext = 0 - 16; sample = sample position to convert

time_seconds = pointer to variable to receive the time in seconds

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Time Series Data

GetTimeSeriesValueFromTime( long channel, float time_seconds, float *value )

Description: Get the time series amplitude value a the specified time

Parameters: channel_ext = 0 - 16; time_seconds = file position time in seconds

value = pointer to variable to receive the time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTimeSeriesValueFromSample( long channel, unsigned long sample, float *value )

Description: Get the time series value a the specified sample position

Parameters: channel_ext = 0 - 16; sample = file position in samples

value = pointer to variable to receive the time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetMaxTimeSeriesValueInSegment( long channel, unsigned long startSample, unsigned long stopSample, float *value )

Description: Get the maximum time series value in the specified time segment

Parameters: channel_ext = 0 - 16;

startSample = time segment start position in samples;

stopSample = time segment stop position in samples;

value = pointer to variable to receive the maximum time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetMinTimeSeriesValueInSegment( long channel, unsigned long startSample, unsigned long stopSample, float *value )

Description: Get the minimum time series value in the specified time segment

Parameters: channel_ext = 0 - 16;

startSample = time segment start position in samples;

stopSample = time segment stop position in samples;

value = pointer to variable to receive the minimum time series amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTimeSeriesFromFile( long channel, SAFEARRAY __RPC_FAR * __RPC_FAR *psaTimes, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of time series data for the specified channel

Parameters: channel_ext = 0 - 16;

psaTimes = pointer to array of time values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTimeSeriesFromFileSegmentSample( long channel, unsigned long startSample, unsigned long stopSample, SAFEARRAY __RPC_FAR * __RPC_FAR *psaTimes, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of time series data for the specified time segement and channel

Parameters: channel_ext = 0 - 16;

startSample = start sample of time series segment;

stopSample = stop sample of time series segment;

psTimes = pointer to array of time values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetTimeSeriesFromFileSegmentTime( long channel, float startSecs, float stopSecs, SAFEARRAY __RPC_FAR * __RPC_FAR *psaTimes, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of time series data for the specified time segement and channel

Parameters: channel_ext = 0 - 16;

startSecs = start time of time series segment;

stopSecs = stop time of time series segment;

psaTimes = pointer to array of time values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetRPM( long channel, float *rpm )

Description: Get the current RPM from the tachometer channel

Parameters: channel_ext = 0 - 16 for main channels

rpm = pointer to variable to receive the RPM value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Spectral Data

GetSpectrumMinFrequency( long channel_ext, float *freq )

Description: Get the minimum available frequency in the spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

freq = pointer to variable to receive the frequency value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSpectrumMaxFrequency( long channel_ext, float *freq )

Description: Get the maximum available frequency in the spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

freq = pointer to variable to receive the frequency value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSpectrumValue( long channel_ext, float freqHz, float *value )

Description: Get the amplitude value of the spectral data at the specified frequency and channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

freqHz = frequency to read the amplitude

value = pointer to variable to receive the amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSpectrum( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetSpectrumInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakHoldSpectrumValue( long channel_ext, float freqHz, float *value )

Description: Get the peak hold amplitude value of the spectral data at the specified frequency and channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

freqHz = frequency to read the amplitude

value = pointer to variable to receive the amplitude value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakHoldSpectrum( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of peak hold spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPeakHoldSpectrumInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of peak hold spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of amplitude values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetComplexSpectrum( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataR, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataI )

Description: Get an array of complex spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

psaFrequencies = pointer to array of frequency values

psaDataR = pointer to array of real component of complex values

psaDataI = pointer to array of imaginary component of complex values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetComplexSpectrumInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataR, SAFEARRAY __RPC_FAR * __RPC_FAR *psaDataI)

Description: Get an array of complex spectral data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaDataR = pointer to array of real component of complex values

psaDataI = pointer to array of imaginary component of complex values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Phase Data

GetPhaseValue( long channel_ext, float freqHz, float *value )

Description: Get the phase value at the specified frequency and channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

freqHz = frequency to read the phase

value = pointer to variable to receive the phase value

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPhase( long channel_ext,SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of phase data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of phase values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

GetPhaseInSpan( long channel_ext, float startHz, float stopHz, SAFEARRAY __RPC_FAR * __RPC_FAR *psaFrequencies, SAFEARRAY __RPC_FAR * __RPC_FAR *psaData )

Description: Get an array of phase data for the specified channel

Parameters: channel_ext = 0 - 16 for main channels, 17 - 32 for composite channels;

startHz = start frequency of selected span;

stopHz = stop frequency of selected span;

psaFrequencies = pointer to array of frequency values

psaData = pointer to array of phase values

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Leq Data

GetLeqValues( long channel, float *LeqT, float *Leq, float *Lsel, float *Lpk, float *Lmax, float *Lmin, float *L10, float* L50, float *L90 )

Description: Get the Leq (Equivalent Noise Level) values for the specified channel

Parameters: channel_ext = 0 - 16

LeqT = pointer to the equivalent noise level converted to the user specified "reference time period".

Leq = pointer to the equivalent noise level for the selected time segment.

Lsel = pointer to the equivalent noise level converted to a 1 second period.

Lpk = pointer to the peak level for the selected time segment. No averaging is used for this parameter.

Lmax = pointer to the maximum level for the selected data.

Lmin = pointer to the minimum level for the selected data.

L10 = pointer to the level exceeded 10% of the time.

L50 = pointer to the level exceeded 50% of the time.

L90 = pointer to the level exceeded 90% of the time.

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter

Misc

GetMetadata( long channel, BSTR* metadata )

Description: Get the metadata text from the current wafe file. Wave file must be open for this function to suceed.

Parameters: channel = 0 -16; metadata - up to 2000 characters max of ascii text

Return: S_OK = success, E_FAIL = unsuccessful, E_INVALIDARG = invalid parameter


Performance Issues

Processing Speed

The processing speed is affected by many factors. Foremost among these is the FFT size. Select a lower FFT size for faster performance but with reduced frequency resolution.

Video speed is major factor. The more plots that are displayed, the greater the demands placed on the video subsystem. The Spectrum plot is the fastest.

The 3-D Surface and Spectrogram plots are significantly slower than the Time Series or Spectrum plots. You may want to close these plots if you are not using them. Alternatively they will run slightly faster if minimized to an icon along the bottom of the display.

See also: FFT size, Settings


Measurement Accuracy

Frequency Accuracy:

The frequency accuracy depends directly on the accuracy of the sampling clock on the DT-9800 device. This is typically a fraction of a Hertz (Hz).

Amplitude Accuracy:

The DT-9800 device produces calibrated voltage values. Consult the specifications provided with your specific DT-9800 data acquisition module for the tolerances. The specific transducer accuracy must be taken into account as well.

Octave Scaling Accuracy:

Historically, spectrum analyzers have utilized analog filters for each band and standards (ANSI S1.11-2004) have been developed which specify the performance of these filters . SpectraPLUS-DT uses a Fast Fourier Transform (FFT) to compute the spectral data and then derives the octave data. This algorithm uses the same ISO center frequencies and bandwidths as analog instruments; however, the FFT filtering method produces much steeper "shoulders". These digital filters meet or exceed the performance of traditional analog filters.

Dynamic Range:

The theoretical dynamic range of the system is as follows:

8 bit sampling precision = 48 dB

16 bit sampling precision = 96 dB

24 bit sampling precision = 144 dB

The actual dynamic range achieved is always less due to electrical noise and other factors.

See also: Scaling, Settings , Calibration


Aliasing

Aliasing is a situation in which the signal being sampled contains frequencies which are greater than 1/2 the sampling rate. If this is the case, the signal will be detected by the analyzer but the frequency will be incorrect. For instance, if the sampling rate is 6,000 Hz and a 3,500 Hz signal is applied to the input, the analyzer will show the signal at 2,500Hz.

Check the specifications of the specific DT-9800 hardware module to determine if the module provides built-in anti aliansing protection.

See also: Sampling Rate, Measurement Accuracy


Technical Support

Please feel free to call or write.

Mail: Pioneer Hill Software LLC, 24460 Mason Rd NW, Poulsbo WA 98370 USA

Voice: 360 697-3472

Email: pioneer@spectraplus.com

Website: www.spectraplus.com

Copyright 1993-2011, PHS

All Rights Reserved.

Legal Notices and Trademark attributions.

All trademarks are the property of their respective owners.


kHz Tone

1 kHz Tone

This 1,000.0 Hz sinewave test tone is widely used for distortion measurements.

See Also: Signal Generator , Multiple Tones , IMD tones


3-D Surface Plot Options

The 3-D Surface display options dialog box can be activated by selecting the <Options><Plot Options><3-D Surface> menu or by clicking on the options dialog icon button in the plot toolbar .

Frequency Span: If "Full Span" is selected, the display will show the entire available frequency span. When "Custom Span" is selected, the frequency values can be directly entered.

Display Update Interval: Normally a new line is added to the plot whenever a new FFT is computed. You may elect to only update the plot every N seconds. This is most useful in the Real-Time mode. In this way, long term frequency -vs- time studies can be conducted.

Plot Top/Range/Bottom: The Plot Top and Range values determine the amplitude values. Plot Top is the value at the upper edge of the plot. The lower edge of the plot is always equal to the Top value minus the Range value. When linear scaling is selected for the amplitude axis, the Plot Range value is set to zero and cannot be changed. When Log Magnitude scaling is selected for the amplitude axis, the Plot Range value changes to become the Plot Bottom value.

Colors: The color of each plot feature can be changed. The "Default" button will restore the initial colors settings. The Multicolor Gradient option displays the data with amplitudes shown in a color gradient; a color bar to the right of the plot shows the amplitude/color relationship and the cursor measurements will also show amplitude values. The "Custom Color" option lets you choose the minimum and maximum colors.

Show Toolbar: Show or hide the plot toolbar. A small + or - button below the toolbar also controls this feature.

Show RPM instead of Time: This will replace the time axis values with RPM values from the tachometer channel. The cursor measurements will also display RPM values.

Copy these settings to other channels: Allows you copy the plot options to other channels you select.

Notes:

  • Any changes to the display option will cause the 3-D Surface plot to automatically rebuild itself with the new settings (press the Escape key to cancel the rebuild). This behavior will not occur when the analyzer is in the Real-Time mode because the underlying time series data is no longer available.

See Also: 3-D Surface Plot


Amplitude Axis Scaling

Two basic amplitude scaling types are linear and logarithmic. They are related by the following equations:

Linear value = 10 ^ (Log value/20)

Log value = 20 * Log10 (Linear value)

Linear amplitude scaling makes the largest components in a spectrum very easy to see and to evaluate, but very small components may be overlooked completely. Linear scaling may be adequate in cases where the components are all about the same size. Logarithmic amplitude scaling clearly shows the low level signals in the presence of stronger signals. Logarithmic scaling is the default.

Log Magnitude scaling uses linear units on a logarithmic scale.


Audio Band

Frequencies in the audible range of hearing (20 to 20,000 Hz)


Averaging Settings

These setting control how the spectral data is averaged.

Averaging Mode

Free Run (blocks) - this is the default mode and updates the analyzer each time a new FFT block of data is computed. In this mode the average block size directly determines how many spectra blocks are averaged together to compute a moving average. For instance, if the averaging block size is set to 4, the spectrum currently displayed is a moving average of the previous 4 traces.

If the signal you are measuring is rapidly changing in frequency, a low averaging block size should be used. Use a high block size to "dig" out a steady state signal buried in a noisy background.

Setting the averaging size to "infinite" causes the program to average successive spectral traces continuously. Stopping and restarting the processor will reset the average.

Sound Level Meter (SLM) - this mode sets the averaging algorithm to match that of a standard Sound Level Meter (SLM). The average speed controls the spectral averaging period and decay time as follows:

  • Off - no averaging is performed.
  • Fast - computes a running average with a decay rate of 32 dB/sec.
  • Medium - computes a running average with a decay rate of 20 dB/sec.
  • Slow - computes a running average with a decay rate of 4 dB/sec.
  • Forever - accumulates the data for as long as the analyzer is running.

Exponential averaging should be used when the Sound Level Meter mode is selected.

Averaging Type

Exponential - this method produces an average where the most recently acquired spectra have more influence on the average than older ones. If you were to suddenly shut off the input signal, the decay rate will follow an exponential curve. Exponential averaging should be used when the Sound Level Meter mode is selected.

Linear - this method is a straight linear average of the spectra over time. Each spectra block contributes equally to the average. This type of averaging is also known as "stable averaging"

Vector - this method performs a complex (vector) average of successive spectra over time. Because vector averaging includes the phase component in the computation, triggering must be employed if meaningful results are to be expected. This type of averaging is also known as "synchronous averaging".

Exponential averaging is the default as it is more computationally efficient.

Notes:

In both the Real-Time and Post-Processing modes, the averaging speed/block size can be modified while processing by using the "Avg" control on the toolbar. The active channel corresponds to the plot which has the "focus" (its title bar is highlighted).

See also: Peak Hold


Contents

Introduction

Welcome

What is a spectrum analyzer?

System Requirements

Getting Started

Basic Operations

Setting up the analyzer

Cursor measurements

Right Mouse Click Actions

Printing the results

Toolbars

Status Bar

Keyboard Shortcuts

File Management

Opening and Saving Wave Files

Importing Files

Exporting Files

File Options

Set Paths

Configuration Files

Editing

Cut/Copy/Paste

Play/Play Special

Filtering

Mute

Gain Adjust

DC Offset

Dynamic DC Offset

Select All

Metadata

Modes

Real-Time

Post-Processing

Recorder

Plots

Time Series

Spectrum

Phase

Spectrogram

3-D Surface

Selecting Single Channel Plots

Selecting Composite Channels

Options

Input Device

Output Device

FFT Settings

Scaling

Calibration

Triggering

Run Control

Utilities

Signal Generator

Save Signal to WAV file

Peak Frequency

Peak Amplitude

Total Power

Total Harmonic Distortion (THD)

Total Harmonic Distortion + Noise (THD+N)

Total Harmonic Distortion + Noise (THD+N) versus Frequency

InterModulation Distortion (IMD

Signal to Noise Ratio (SNR

Signal to Noise Plus Distortion (SINAD

Reverberation Time

Equivalent Noise Levels

Sound Power Level

Order Analysis

Licensing

Status and Authorization

Automation

Data Logging

COM API

Performance Issues

Processing Speed

Measurement Accuracy

Aliasing

Misc

Technical Support


Digital Zero

Generates a signal containing all zero's or silence.


DTMF

Produces a series of dual tone pulses (touch tones) for the specified key string. You may also adjust the pulse width, spacing and twist.

Twist is entered in dB. A positive twist value means that the amplitude of the higher frequency tone will be greater than the low frequency tone by this amount. Negative twist values produce the opposite effect.

Please note that the full extended DTMF character set is supported (1234567890*#ABCD).

See Also: Right Click Action Menus


FFT

FFT is an abbreviation for a Fast Fourier Transform.

The Fourier Transform is a mathematical tool developed and named after Jean Baptiste Fourier (1768 - 1830) and is commonly used to convert a signal from the time domain (amplitude-vs-time) to the frequency domain (amplitude-vs-frequency). A frequency domain plot is also known as a spectra plot.

The Fast Fourier Transform (FFT) is a computationally efficient implementation of the Fourier Transform developed by J.W. Cooley and J.W. Tukey in 1965. The Fast Fourier Transform is limited to block sizes which are even powers of 2.

For example, if a FFT is performed on a pure sinusoidal signal, the resulting spectra would be single peak (line). Real world signals are a composite of many sinusoidal signals; examining the signal's spectra clearly shows the frequency tones which are present.


FFT Size

The selected FFT size directly affects the resolution of the resulting spectra. The number of spectral lines is always 1/2 of the selected FFT size. Thus a 1024 point FFT produces 512 output spectral lines.

The frequency resolution of each spectral line is equal to the Sampling Rate divided by the FFT size. For instance, if the FFT size is 1024 and the Sampling Rate is 8192, the resolution of each spectral line will be:

8192 / 1024 = 8 Hz.

Larger FFT sizes provide higher spectral resolution but take longer to compute.

The current FFT size is always displayed in the status bar along the bottom of the application for the active channel. The active channel corresponds to the plot which has the "focus" (its title bar is highlighted).

See also: Sampling Rate


Frequency Axis Scaling

There are two basic types of frequency axis scaling: Narrowband and Octave. Narrowband scaling can be displayed in either Linear or Logarithmic format; Octave scaling is always displayed in Logarithmic format.

Narrowband Scaling

The spectrum produced by an FFT algorithm is also known as a narrowband spectrum. Each spectral line is a constant bandwidth and typically quite narrow. This narrowband spectral data can be displayed on either a linear or logarithmic scale but the frequency resolution is determined by the sampling rate and FFT size and remains unchanged as you increase in frequency.

The resolution of each spectral line is equal to:

Resolution = Sampling Rate / FFT size

Octave Scaling

Octave scaling produces a set of bands with constant proportional bandwidth. You can select from a range of octave formats. 1/1 and 1/3 octave are the most commonly used formats. See the Octave Scaling topic for more details.

See Also: Amplitude Axis Scaling , Scaling


Frequency Step

Frequency Step (stepped sine)

The frequency step waveform produces a sine wave which changes frequency over time in discrete steps. The start and stop frequencies determine the limits of the signal. The start frequency can be less than the stop frequency in which case the frequency will decrease over time.

The step size can be either Linear or Octave (logarithmic).

Linear Steps - specify the step size in Hz. This works best when narrowband scaling is used on the analzyer.

Octave Steps - specify the fractional octave steps size to use. This works best when the octave scaling is used on the analyzer.

Jump Back to Start Frequency - when the stop frequency is reached the signal will immediately start again at the start frequency

Sweep Back to Start Frequency - when the stop frequency is reached the signal will step back to the start frequency.

Stop After a Single Pass - the signal generator will stop after the sequence completes; otherwise it will repeat continuously until the generator is stopped.

Dwell Time - specifies how long the signal stays at each step in the sequence. This value is specified in milliseconds.

Stepped sine waveforms are useful for frequency response testing. Set the averaging block size to 1 and use the Peak Hold option to capture the peak amplitude as the signal is stepped across the frequency span.

See Also: Freq Sweep , Signal Generator


Frequency Sweep

Frequency Sweep (Swept Sine)

The swept sine waveform produces a sine wave which changes frequency over time. The start and stop frequencies determine the limits of the sweep signal. The start frequency can be less than the stop frequency in which case the sweep frequency will decrease over time.

The sweep type can be either Linear or Logarithmic. This determines the rate of change of the sweep frequency.

Jump Back to Start Frequency - when the stop frequency is reached the signal will immediately start again at the start frequency

Sweep Back to Start Frequency - when the stop frequency is reached the signal will sweep back to the start frequency.

Stop After a Single Sweep - the signal generator will stop after the sweep completes; otherwise it will repeat continuously until the generator is stopped.

Sweep Time - specifies how long the frequency takes to change from the start to the stop limits. This value is specified in milliseconds.

Swept sine waveforms are useful for frequency response testing. Set the averaging block size to 1 and use the Peak Hold option to capture the peak amplitude as the signal is swept across the frequency span. The larger the FFT size used, the longer the required sweep time.

Sweeping too fast with large FFT sizes will "smear" the amplitude as the signal is changing frequency withing the underlying time series segment.

See Also: Level Step , Signal Generator


Order Analysis

Order Analysis is a technique used for spectral analysis of rotating machinery. Order is defined as the normalized rotational speed. The first order is the basic rotational speed and order M is N times the rotational speed. Order components are harmonically related to the rotational speed.

Order Analysis:

  • Converts Frequency into Orders
  • Reveals which spectral components are related to the rotational speed of the machine because all the shaft related peaks line up
  • Allows you to separate structural resonances (fixed frequencies) from rotational ones (variable frequencies)
  • Requires a tachometer (Data Translation DT9826, DT9837, DT9839 or DT9857)

With rotating machinery, many vibrational properties change with speed. You only can observe some mechanical faults, such as resonance, as the rotational speed approaches or passes the critical speed. For this reason, machinery tests often require run up or coast down tests.

Order Analysis is supported by the analyzer and can be used in any of the modes (Realtime, Recorder or Post Processing).

Connect a tachometer to the Data Translation module and enable the tachometer channel and one or more input channels under the Options - Processing Settings - Device Input menu. Also connect the accelerometers or microphones to their respective input channels.

Order Analysis is performed primarily using the Spectrogram plot . This plot normally displays Frequency vs Time with the Amplitude in color. If tachometer data is available the spectrogram can be configured to display RPM instead of Time and Order instead of Frequency. These options are selected in the Spectrogram Plot Options dialog box.

If you double click on the spectrogram, the Order Spectrum plot will be displayed at the RPM corresponding to the mouse position.


Decimation

The decimation ratio value controls the ratio with which the digitized audio is down-sampled". This feature is used to achieve a lower sampling rate <sampling_rate.htm>. This will allow greater frequency resolutions at low frequencies for vibration measurements and similar applications. For instance, if the sampling rate is 8000 Hz, decimating by a factor of 10 will effectively reduce this to 800 Hz. The resulting measurement range will then be 0 to 400 Hz.

A value of 1 will not decimate the data at all.

Decimation is actually a very simple process. Let's say we want to down-sample by a factor of 8:1, all we need to do is to throw away 7 out of every 8 samples.

You need to be careful when decimating to make sure that the original signal contains no energy above the "new" Nyquist frequency otherwise aliasing will occur. If this is not the case you should either use an external low pass filter or check the box labeled "Apply Low Pass Filter when Decimating".

Note:

The Time Series view always displays data prior to the decimation process.

See also: FFT Size , Filtering


IMD Test Tones

InterModulation Distortion ( IMD ) testing requires two independent tones at different amplitudes. The amplitude of the higher of the two tones is typically 12dB (4:1 ratio) lower than the low frequency tone. Several standard tone pairs are provided as well as the ability to select your own custom tones.

See Also: Signal Generator , Multiple Tones , IMD


Level Sweep

The level sweep waveform produces a sine wave which changes amplitude over time. You select the start and stop levels in decibels, the tone frequency, and sweep time. The start level can be less than the stop level in which case the signal level will decrease over time.

The sweep time specifies how long the level takes to change from the start to the stop limits. This value is specified in milliseconds. The sweep will repeat continuously until the generator is stopped.

See Also: Frequency Sweep , Signal Generator


Main Toolbar

The contents of the main application toolbar depend upon the Mode. Each toolbar contains icon buttons for controlling the processor status (Run/Stop etc). In addition, the Real-Time and Post-Processing modes contain controls for adjusting the averaging block size status on the fly. These controls duplicate the functionality found in the Settings dialog box. The averaging settings and scrollbar values correspond to the channel who's plot which has the "focus" (its title bar is highlighted).

The Recorder and Post-Processing modes have a horizontal scrollbar which tracks the current position within the .WAV file. The left-hand label shows the current position within the file and the right-hand label shows the total time in the file.

Real-Time

Run Start the processor

Stop Stop the processor

Avg Adjust the averaging block size for the active channel (plot that has the "focus")

Recorder

Rec Begin recording data

Stop Stop recording or playing

Fwd Move current position to end of the file

Rwd Move current position to beginning of the file

Avg Adjust the averaging for the active channel (plot that has the "focus")

Scroll Adjust current position within the file.

Post-Process

Run Start the processor

Stop Stop the processor

Rwd Move the current position to beginning of the file

Avg Adjust the averaging for the active channel (plot that has the "focus")

Scroll Adjust the current position within the file

Load Configuration - quickly load a configuration file

See Also: Secondary Toolbar , Plot Toolbars


Markers

Markers are used to highlight specific frequencies of interest on the Spectrum Plot.

Labels can be applied to the spectrum plot . If custom labeling is selected, you may enter up to 30 characters of text.

Markers can also be set graphically by clicking the right mouse button in the spectrum plot. This will bring up the Right Click Action Menu . Choosing one of the "Set Marker #" commands will set the marker frequency corresponding to the mouse click position. The "Clear All Markers" option will simply hide all markers; they can be reactivated by enabling them in the <Options><Markers> dialog box.


Transducer Compensation

An ideal transducer would have a perfectly flat frequency response (all frequencies detected with equal amplitude). In practice, most transducers do not meet this criteria. Transducer compensation curves allow the analyzer to apply a correction curve to the data to solve this problem.

Measurement transducers normally provide a frequency response curve for with their products. This curve shows both the total frequency range covered and the frequency response of the transducer within this range. By creating a simple text file containing this information, we can compensate for its response.

Building a compensation file:

Run the NOTEPAD.EXE application, spreadsheet or word processor that can produce a standard ASCII text file.

Enter two columns of numbers representing the transducer response curve.

The left column contains the frequency in Hertz.

The right column contains the offset in decibels (this offset is subtracted from the logarithmic spectrum value).

Enter the information in ascending frequency order.

Separate the columns with a tab character.

Example:

---------------------------

100.0 -10.0

500.0 -5.0

1000.0 0.0

2000.0 2.0

10000.0 -5.0

15000.0 -15.0

Enter as many as32,768 pairs of numbers; at least 3 pair are required. The analyzer will use a cubic spline algorithm to interpolate between these data points for each frequency bin in the spectrum.

Any line with a semicolon in the first column will be treated as a comment line and ignored.

Transducer compensation files have an extension of .MIC.

Note:

Transducer Compensation files and Spectral Overlay files have identical formats and can be interchanged. This is useful if you want to verify that you have entered the transducer response table correctly. To do this, simply select the compensation file as an overlay.

Interpolation: When manually creating a compensation file the results can have unexpected excursions due to the cubic spline interpolation algorithm. You can turn off this algorithm by adding a line to the beginning of the file as follows:

;SPLINE OFF

See also: Standard Frequency Weighting


Multiple Tones

This signal generator options allows you to configure your own set of tones. The tone waveform consists of up to 10 user defined tonals. You can select the number of active tones, their frequencies, relative amplitudes and phase.

The check box to the left of the frequency setting determines whether or not the tone is enabled. If the box is not checked, the associated tone will not be generated.

The frequency setting determines the tone frequency in cycles per second.

The relative power setting determines the amplitude of the tone compared to the other tones being generated. The power is specified in decibels (dB).

The phase setting determines the phase offset at the start of the waveform.

Apply Dithering - Dithering is intentional noise which is added in order to randomise the quantisation errors (rounding errors) when computing the waveform in order to reduce distortion. The noise itself isn't audible unless heavily amplified. Dithering is applied to all signal types but this option allows you to disable it for certain types of applications. It only disables it for the multitone signal type. The Dithering algorithm used is a triangular probability density function (TPDF) at a level of 1LSB pk-pk.

Load/Save: allows you to easily change between sets of tones. Creates a simple INI type file with the tone settings. The file extension is .tones and is located in the /Config folder by default

See Also: Signal Generator , 1 kHz Tone , IMD Tones


Noise Burst

This option allows you to generate a burst of noise. The "Burst Time" defines the length of the noise period. The "Cycle Time" specifies the repetition period. For instance, if the Burst Time is set to 1000 msec and the Cycle Time is set to 2000 msec, the generator will output 1 second of silence followed by 1 second of noise. This pattern will repeat until the generator is stopped.

See Also: Pink Noise , White Noise , Generator Output Level


Octave Scaling

Octave band analysis has been defined as a standard for acoustic analysis. This type of spectrum is called constant percentage band (CPB) because each frequency band is a constant percentage of its center frequency. In other words, the analysis bands become wider in proportion to their center frequencies. 1/1 and 1/3 octave spectra are the most frequently used formats in acoustical measurements - three 1/3 octave bands encompass one octave.

It can be argued that the frequency resolution in octave band analysis is too poor to be of much use, but a major advantage of constant percentage band analysis is that a very wide frequency range can be displayed on a single graph and the frequency resolution at the lower frequencies can still be fairly narrow. The naturally occurring ambient spectra will be found to slope downwards at the highest frequencies, and a constant percentage band (CPB) spectrum of the same data will usually be more uniform in level over a broad frequency range. Pink noise slopes downward at 3dB per octave and produces a perfectly flat octave spectrum.

Standard octave band center frequencies and bandwidths have been agreed upon by the international community. These standards are used by SpectraPLUS-DT.

Most octave analyzers are analog instruments and use analog filters for each band. SpectraPLUS-DT is a digital analyzer and utilizes the FFT algorithm to compute the narrowband (linear) frequency spectrum. This linear frequency spectrum is then apportioned among the octave bands to produce the corresponding octave spectrum.

As you would expect, the FFT size directly determines the number of octave bands that can be computed. At the low frequencies, there are only a small number of narrowband bins which fall within the corresponding octave band limits. The number of 1/3 Octave bands produced for various FFT sizes are listed below:

FFT size Number of 1/3 Octave bands

32 3

64 6

128 10

256 13

512 16

1024 19

2048 22

4096 25

8192 28

16384 31

32768 34

65536 36

The actual band frequencies are determined by the sampling rate

See also: Scaling, FFT size


Overlap Percentage

This powerful feature allows the time axis on the Spectrogram and 3-D Surface plot to be "stretched" by re-processing portions of the time series. The setting determines what percentage of the FFT size block of data points is re-used for the next trace. High overlap percentages (90+%) and low FFT block sizes provide the highest time resolution but take longer to process the data file. This feature is only used in Post-Processing mode.

Large FFT sizes produce high frequency resolution but poor time resolution while low FFT sizes have the opposite effect. Overlap processing can be used to provide high resolution in both the frequency and time axis. For example, if a signal contains two discrete tones separated in frequency, only one of which is on at a time, it is difficult to discern the relative timing of each tone because both frequencies are often contained within a single FFT size time series block. If we perform an FFT and, instead of moving forward a whole FFT size block in the series, move forward only a small amount then we can isolate the pulse timing for each tone. The following figure illustrates the effect of overlap processing

Notice that 4 times as many FFT's are performed in the second case; this will increase the time resolution by a factor of 4.

The program can automatically compute and use the optimum overlap percentage for you. Using either the Time Series, 3-D Surface or Spectrogram plots, simply select a time segment for editing and right click anywhere in the plot. An Action Menu will appear with choices such as "Compute and Display Spectrogram". The analyzer will automatically compute the overlap percentage necessary to fill the plot from the selected time segment. See the Right Click Action Menu topic for more details.

Notes:

High overlap percentages will require greater processing times.

See also: Right Click Action Menus , FFT size , Smoothing Windows,


Overlays

The overlay feature allows you to display multiple spectral traces on the same plot for quick comparisons with previous measurements. The overlay controls are shown on the right side of the spectrum plot. These can be quickly hidden using the small + or - button below the overlay controls.

Up to 12 overlays can be displayed for each channel. In addition, two "Composite" overlays can be set which is computed from other overlays.

Spectral Overlay Operations

Clicking one of the numbered "Set" overlay buttons will create an overlay using the contents of the current spectrum. The overlays can be turned On and Off by clicking the checkbox labeled "On".

Clicking the "Options" button brings up a dialog box with additional controls:

Legend: You may enter a descriptive legend up to 24 characters long. This legend is displayed on the spectrum plot and printed on any printouts. The legend is saved as part of the overlay file format and restored whenever you load the file from disk.

Offset: You can apply an offset in dB to each overlay; this is useful for aligning overlays for comparison purposes.

Disk Storage: Use these controls to save and load the overlay traces from disk. Any offset specified is NOT included in the saved overlay file contents.

Trace Colors: these controls allow you to select the display colors for each of the overlay traces and legends. These colors are also used when printing the spectrum plot on a color printer. If you print to a monochrome printer, each of the overlays will have a unique line style.

Legend Display Size: this value will adjust the width of the rights border of the spectrum plot to show the specified number of legend characters. Space may be reserved for up to 24 characters.

Overlay File Format:

Overlay files can be created manually. Overlay files are simple ASCII text files containing two columns of numbers separated by a tab. The left column contains the frequency; the right column contains the corresponding amplitude value. If a semicolon is placed on the first column, the entire line will be treated as a comment and ignored. Legends are the first line in the file and have a semicolon in the first column. At least 3 data points are required and up to 32768 points can be used.

A cubic spline algorithm is used to interpolate between each data point. This file format is interchangeable with the transducer compensation file format.

Composite Overlay

Pressing the overlay button labeled "C1" or "C2" will allow you to setup a "Composite" overlay. The composite overlay can be either an average of up to 12 selected overlays or the difference between any 2 selected overlays. Any offset selected for the dependent overlays is applied when the composite values are computed. An offset can also be applied to the composite overlay itself.

Note: If you regularly interchange overlay and transducer compensation files, you may want to set their file paths (See Set Paths command) to the same directory. You can then easily select whether to use .MIC or .OVL file types from the file open/save dialog boxes.

Interpolation: When manually creating overlays the results can have unexpected excursions due to the cubic spline interpolation algorithm. You can turn off this algorithm by adding a line to the beginning of the overlay file as follows

;SPLINE OFF

This can also be done with transducer compensation files.


Overload Indication

Overload is a condition where the input signal strength exceeds the full scale sensitivity of theA/D channel. Known in the analog world as "clipping", it will cause severe distortion to occur.

The analyzer will test each incoming data block to determine if an overload condition is present and display a message in the status bar along the lower edge of the application. This message is shown in bright red and is very noticeable.

If an overload condition occurs, you will need to either reduce the input signal strength or decrease the input gain of the channel in the Input Device settings.

See Also; Settings , Calibration


Peak Hold

When Peak Hold is used, the analyzer will display a secondary trace showing the highest amplitude values for each frequency bin. Selecting Fast, Medium or Slow will cause the peak hold values to temporarily hold before resetting. Forever will hold the values without releasing them. Stopping and restarting the processor will reset the peak hold values.

Peak Hold can be controlled from either the Spectrum Plot Options dialog box or from the spectrum plot toolbar .

See also: Averaging Settings


Phase Plot Options

The phase display options dialog box can be activated by selecting the <Options><Plot Options><Phase> menu or by clicking on the options dialog icon button in the plot toolbar .

Plot Top/Range: The Plot Top and Range values determine the phase axis scale values. Plot Top is the value at the upper edge of the plot. The lower edge of the plot is always equal to the Top value minus the Range value.

Pull Cursor to Trace: If this option is enabled, the measurement cursor will automatically "pull" to the trace along the phase axis.

Colors: The color of each plot feature can be changed. The "Default" button will restore the initial colors settings.

Grid Lines: Show or hide the grid lines.

Show Toolbar: Show or hide the plot toolbar. A small + or - button below the toolbar also controls this feature.

Frequency Span: Although the displayed frequency span can easily be selected using the zoom buttons on the toolbar, you can also manually enter the span yourself. The span is limited to the total available span. The actual span displayed may vary slightly from the requested values because the values are adjusted to the nearest bin.

Display Update Interval: Controls how often the display is updated. This is useful on some laptop computers with slow display refresh rates to reduce flicker.

Copy these settings to other channels: Allows you copy the plot options to other channels you select.

See Also: Phase Plot


Pink Noise

Pink noise is a commonly used random noise waveform in acoustics. It has more energy at the lower frequencies. It's amplitude decreases at a rate of 3dB per octave. Its averaged spectrum is flat when ploted on an octave spectrum analyzer. The cutoff frequency is governed by the sampling rate used by the analyzer.

See Also: White Noise , Signal Generator


Plot Toolbars

Selection Arrow: Allows you to graphically select a time segment to edit. Click the selection arrow, then click and drag the mouse across a range of data. When the mouse button is released, the selected time segment will be shown with inverse video. Edit operations (playback, filtering, cut/copy/paste) can then be performed.

Playback Button: Playback the selected time segment. A time segment must first be selected. This performs the same action as the <Edit><Play> menu item.

Filter Button: Filter the selected time segment. A time segment must first be selected. This performs the same action as the <Edit><Filter> menu item

Zoom Selector: Allows you to graphically select the region to expand. Click the Zoom Selector button, then click and drag the mouse across a range of frequency/time data. When the mouse button is released, the display will zoom in to show only the selected data set.

Zoom In 2X: Adjusts the horizontal axis to display one half as many data points.

Zoom Out 2X: Adjusts the horizontal axis to display twice as many data points.

Zoom Out Full: Shows the entire range of frequency/time.

Display options button: Activates the display options dialog box for the associated plot. This performs the same action as the <Options><Spectrum> menu item.

Line Graph button: Changes the spectrum plot type to a Line Graph.

Stepped Bar Graph button: Changes the spectrum plot type to a Stepped Bar Graph.

Bar Graph button: Changes the spectrum plot type to a Bar Graph.

Autoscale button: Evaluates the currently displayed data and sets the Plot Top/Range parameters to optimum settings.

Markers: Access the marker settings (spectrum plot only)

Plot Top: Changes the value of the top edge of the amplitude axis scale. This corresponds to the same control in the display options dialog box for the plot. Clicking on the up/down arrows allows you to quickly adjust the plot window as needed.

Plot Range: Changes the total displayed range of the amplitude axis scale. This corresponds to the same control in the display options dialog box for the plot. Clicking on the up/down arrows allows you to quickly increase or decrease the displayed dynamic range.

Hiding the Toolbar: A small + or - button below the toolbar allows you to hide or show the toolbar. The <Plots><Plot Toolbars> menu allows you to quickly hide or show the toolbars for all channels.

See Also: Main Toolbar , Secondary Toolbar


Power Spectral Density

The Power Spectral Density option causes the analyzer to normalize the spectrum to a 1 Hz bandwidth. This is used for making noise power measurements. For instance, when measuring a noise signal without the PSD option selected, the amplitude will change with FFT size and sampling rate. Using the PSD option, the resulting amplitude will be independent of FFT size and sampling rate.

You can select between Units / Sqrt(Hz) or Units^2/Hz.

Units^2/Hz - this produces the power (squared magnitude) spectral density.

Units / Sqrt(Hz) - this produces the linearized power spectral density

Octave scaling is not allowed when using the PSD option.

Note: The PSD option is used for noise type signals; it is not accurate for sinusoid (tonal) type sigals.

See Also: Scaling


Pulse Waveform

The Pulse waveform produces a single pulse. The width of the pulse and the repetition interval can be adjusted by clicking the "Details" button. If the "One Shot Pulse" option is checked, the generator will automatically stop after the pulse has been emitted. Press the "Run" button to generate another pulse.

See Also: Signal Generator , Squarewave


RPM Utility Window

The <Utilities><Tachometer RPM> menu command will open a resizeable window with the current RPM value from the tachometer channel.

See Also: Tachometer Channel


Sampling Format

An important factor in determining the quality of the sampled sound is the number of bits per sample. This specifies the number of discrete levels that are used in the analog to digital (A/D) conversion process and directly affects the dynamic range of the measurement. The theoretical dynamic range is shown below:

8 bit sampling precision = 48 dB

16 bit sampling precision = 96 dB

24 bit sampling precision = 144 dB

In practice, the achievable dynamic range is less that the theoretical maximum due to internal noise and other factors. Refer to your DT-9800 data acquisition module documentation for the actual performance figures.

See also: FFT size , Scaling, Measurement Accuracy


Sampling Rate

SpectraPLUS-DT allows you to select any Sampling Rate supported by the currently selected DT-9800 data acquisition module. The measured frequency range is always 0 to 1/2 the Sampling Rate.

The Sampling Rate determines how many times a second that the analog input signal is "sampled" or digitized by the input device. A sampling rate of 10,000 Hz will sample the signal every .0001 second. The possible range of sampling rates are limited by the capability of your input device.

An important principal from digital signal processing is the "Nyquist Sampling Theorem" which states that any signal can be represented if sampled at least twice the rate of the highest frequency of interest. This means that if you wish to measure a 3,000 Hz signal, the sampling rate must be greater than 6,000 Hz. A note of caution: if there are unwanted signals which are greater than 3,000Hz, Aliasing will occur.

When a .WAV file is opened, the Sampling Rate and Format is changed to match the rate at which the file was originally recorded; the sampling rate cannot be changed - it must remain constant within a single .WAV file. The current sampling rate is always displayed in the status bar along the bottom of the application; the value corresponds to the channel who's plot has the "focus" (its title bar is highlighted).

See also: Aliasing, FFT size


Sawtooth

The Sawtooth waveform produces a continuous train of ramps. The frequency and slope of the sawtooth can be adjusted by clicking on the "Details" button on the main screen. The Frequency setting specifies how many ramp cycles are generated each second. The Slope setting specifies whether the ramp rises or falls over time.

See Also: Signal Generator


Secondary Toolbar

The secondary toolbar is located just below the main toolbar along the top edge of the application.

Buttons

File New - Brings up the File Management dialog box

File Open - Open one or more existing WAV files using the File Management dialog box

File Save - Save the current WAV files

Print - Print the active plot (time series, spectrum, phase, spectrogram, or 3-D surface)

I/O Device Settings - Brings up the Input Device dialog box

FFT Settings - Brings up the FFT settings dialog box

Scaling - Brings up the Scaling options dialog box

Calibration - Brings up the Calibration dialog box

Triggering - Brings up the Triggering options dialog box

Run Control - Brings up the Run Control options dialog box

Select Single Channel Plots - brings up the Plot Selection dialog box

Select Composite Channel Plots - brings up the Composite Plot selection and configuration dialog box

Signal Generator - open/close the signal generator

Hz - open/close the Peak Frequency utility

dB - open/close the Peak Amplitude utility

Pwr - open/close the Wideband Level (total power) utility

THD - open/close the Total Harmonic Distortion utility

THD+N - open/close the Total Harmonic Distortion + Noise utility

THD+N vs Freq - open/close the THD+N vs Frequency utility

IMD - open/close the InterModulation Distortion utility

SNR - open/close the Signal to Noise Ratio utility

Leq - open/close the Equivalent Noise Level (Leq) utility

Log - open/close the Data Logging options

Rvb - open/close the Reverberation Time utility

See Also: Main Toolbar , Plot Toolbars


Processing Settings

Click the <Options><Processing Settings> menu (or press F4) access the main processing settings dialog box. You can also click one of the corresponding toolbar buttons to go directly to the desired tab.

The Processing Settings dialog box contains the following sections (tabs):

Input Device

Output Device

FFT Settings

Scaling

Calibration

Triggering

Run Control


Smoothing Windows

If a sinewave is passing through zero at the beginning and end of the time series, the resulting FFT spectrum will consist of a single line with the correct amplitude and at the correct frequency. If, on the other hand, the signal level is not at zero at one or both ends of the time series record, truncation of the waveform will occur, resulting in a discontinuity in the sampled signal. This discontinuity causes problems with the FFT process, and the result is a smearing of the spectrum from a single line into adjacent lines. This is called "leakage"; energy in the signal "leaks" from its proper location into the adjacent lines.

Leakage could be avoided if the time series zero crossings were synchronized with the sampling times, but this is impossible to achieve in practice. The shape of the "leaky" spectrum depends on the amount of signal truncation, and is generally unpredictable for real signals.

In order to reduce the effect of leakage, it is necessary that the signal level is forced zero at the beginning and end of the time series. This is done by multiplying the data samples by a "smoothing window" function, which can have several different shapes. The difference between each smoothing window is the way in which they transition from the low weights near the edges to the higher weights near the middle of the sequence. If there is no windowing function used, this is called "Rectangular", "Flat", or "Uniform" windowing.

While the smoothing window does a good job of forcing the ends to zero, it also adds distortion to the time series which results in sidebands in the spectrum. These sidebands, or side lobes, effectively reduce the frequency resolution of the analyzer; it is as if the spectral lines are wider. The measured amplitude of the weighted signal is also incorrect because a portion of the signal level is removed by the weighting process. To make up for this reduction in power, windowing algorithms give extra weight to the values near the middle of the sequence.

The figure shown below compares the spectrum of a signal using a Uniform window and a Blackman window. Remember that a Uniform window is actually no window at all.

Characteristics of various smoothing windows

Window Frequency Amplitude Leakage

Type Resolution Resolution Suppression Application

Bartlett Fair Fair Moderate

Blackman Fair Good Excellent Distortion Measurements

Exponential Fair Fair Poor Transient Measurements such as impact hammer (use for the accelerometer input channel)

Flattop Poor Excellent Moderate Accurate Amplitude measurements

Force Fair Good Poor Impact Hammer tests (use for the impact hammer input channel)

Hamming Fair Fair Fair

Hanning Fair Excellent Excellent Distortion measurements, Noise measurements

Kaiser Fair Fair Poor

Parzen Fair Fair Poor

Triangular Fair Fair Poor

Uniform Excellent Poor Poor High resolution frequency measurements, Impulse response measurements

Gaussian Excellent* Poor Good Allows very high frequency resolution using gaussian interpolation*

*Gaussian interpolation is used for the Peak Frequency Utility, Data Logging and Automation Peak Frequency values.

Advanced Window Settings

Clicking the "Advanced Settings" button allows you to specify additional parameters for certain window types. For more information please refer to the following links:

https://en.wikipedia.org/wiki/Window_function

https://en.wikipedia.org/wiki/Kaiser_window

https://en.wikipedia.org/wiki/Exponential_decay

Notes:

The Time Series Plot displays the signal prior to the application of any smoothing window except when previewing trigging waveform.

The effects of these functions are most noticeable when using Logarithmic scaling.

See also: Scaling, FFT size, Overlap Processing , Sampling Rate


Spectrogram Plot Options

The spectrogram display options dialog box can be activated by selecting the <Options><Plot Options><Spectrogram> menu or by clicking on the options dialog icon button in the plot toolbar .

Frequency Span: If "Full Span" is selected, the spectrogram will show the entire available frequency range. When "Custom Span" is selected, the frequency values can be directly entered.

Display Update Interval: Normally a new line is added to the spectrogram whenever a new FFT is computed. You may elect to only update the spectrogram every N seconds. This is most useful in the Real-Time mode. In this way, long term frequency -vs- time studies can be conducted.

Colors: There are three choices of palettes. The "Color" palette transitions from black to red, the "Grayscale" palette changes from white to black, and the "Custom" palette lets you choose the minimum and maximum colors.

Scroll Direction: Specifies the direction in which the spectrogram will scroll with increasing time.

Scroll Type: Specifies the type of scrolling. Smooth continuous scrolling scrolls the display with new information added at the edge. Overlapped scrolling does not scroll the display but overlaps when the end of the display is reached.

Plot Top/Range/Bottom: The Plot Top and Range values determine the amplitude (color bar) values. Plot Top is the value at the upper edge of the color bar. The lower edge of the color bar is always equal to the Top value minus the Range value. When linear scaling is selected for the amplitude axis , the Plot Range value is set to zero and cannot be changed. When Log Magnitude scaling is selected for the amplitude axis, the Plot Range value changes to become the Plot Bottom value.

Show Toolbar: Show or hide the plot toolbar. A small + or - button below the toolbar also controls this feature.

Show RPM instead of Time: This will replace the time axis values with RPM values from the tachometer channel. The cursor measurements will also display RPM values.

Show Order instead of Frequency: This will replace the frequency axis values with Order values computed from the tachometer channel. The cursor measurements will also display Order values.

Notes:

Any changes to the display options (with the exception of Direction) will cause the spectrogram to automatically rebuild itself with the new settings (press the Escape key to cancel rebuilding). This behavior will not occur when the analyzer is in the Real-Time mode because the underlying time series data is no longer available.

Copy these settings to other channels: Allows you copy the plot options to other channels you select.

See Also: Spectrogram Plot Order Analysis


Spectrum Plot Options

The spectrum display options dialog box can be activated by selecting the <Options><Plot Options><Spectrum> menu or by clicking on the options dialog icon button in the plot toolbar .

Plot Type: You can change between line and bar graphs by clicking on the toolbar controls or from the spectrum display options dialog box. For optimum display performance, the line or stepped bar graph option is recommended when using large FFT sizes and narrowband scaling. The bar graph option is recommended when Octave scaling is selected or when zoomed in with narrowband scaling.

Plot Top/Range/Bottom: The Plot Top and Range values determine the amplitude axis scale values. Plot Top is the value at the upper edge of the plot. The lower edge of the plot is always equal to the Top value minus the Range value. When Linear scaling is selected for the amplitude axis, the Plot Range value is set to zero and cannot be changed. When Log Magnitude scaling is selected for the amplitude axis, the Plot Range value changes to become the Plot Bottom value.

Peak Hold: Displays a secondary trace showing the highest amplitude values for each frequency bin. Selecting Fast, Medium or Slow will cause the peak hold values to temporarily hold before resetting. Forever will hold the values without releasing them. Stopping and restarting the processor will reset the peak hold values.

Pull Cursor to Trace: If this option is enabled, the measurement cursor will automatically "pull" to the spectrum trace along the amplitude axis.

Pull to Peak Hold if enabled: this allows you to have the cursor pull to the peak hold trace instead of the normal trace. If peak hold is off the cursor will pull to the normal trace.

Thick Traces and Markers: Increases the line thickness of these items for better visibility on some displays

Colors: The color of each plot feature can be changed. The "Default" button will restore the initial colors settings.

Marker Options: Setup the markers . The marker settings can also be accessed by clicking the "Mrk" button on the spectrum plot toolbar.

Grid Lines: Show or hide the grid lines.

Show Toolbar: Show or hide the plot toolbar. A small + or - button below the toolbar also controls this feature.

Show Overlay Controls: Show or hide the overlay controls on the right side of the Spectrum Plot. A small + or - button below the overlay controls also controls this feature.

Frequency Span: Although the displayed frequency span can easily be selected using the zoom buttons on the toolbar, you can also manually enter the span yourself. The span is limited to the total available span. The actual span displayed may vary slightly from the requested values because the values are adjusted to the nearest bin.

Display Update Interval: Controls how often the display is updated. This is useful on some laptop computers with slow display refresh rates to reduce flicker.

Show Total Power Meter: the total power meter is located along the right side of the spectrum plot and shows the "Total" power of the spectral data. This value is equal to the Total Power utility. A different weighting curve can be applied to this value (this is set in the Scaling dialog box). A small + or - button below the meter also controls this feature.

Show Zoomed Power Level: If enabled, the RMS Power level will be computed and displayed above the top left corner of the plot. This power level is computed for the currently displayed span and will change as you zoom in and out. Use this feature to compute the power within any segment of the spectrum. The weighting used for this calculation is the same as the spectrum weighting parameter in the scaling dialog box.

Copy these settings to other channels: Allows you copy the plot options to other channels you select.

See Also: Spectrum Plot , Plot Toolbar


Squarewave Signal

The Square waveform consists of a continuous series of pulses. The frequency and duty cycle of the square wave can be adjusted by clicking the "Details" button on the main screen. The Frequency setting determines the number of pulses generated each second. The Duty Cycle setting determines the pulse width as a percentage of the period.

See Also: Signal Generator , Pulse waveform


Standard Frequency Weighting

ANSI standard A, B and C weighting curves can be applied to the spectral data and/or to the total power value. The total power setting affects the values shown in the total power utility and on the total power bar along the right side of the spectrum plot if enabled. Flat is equivalent to no weighting at all. Weighting functions emphasize frequencies in the 500 to 10,000 Hz range, which is the area of greatest sensitivity to the human ear.

See also: Scaling, Transducer Compensation , Octave Scaling


Tachometer Channel

The DT-9837, DT9839 and DT-9826 modules include a tachometer input channel. When this device is selected for input, the tach channel will be labeled as "Tachometer Input Channel" on the Input Device dialog.

Ticks/Rev: This parameter allows you to specify how many tachometer pulse ticks equals one revolution of the shaft.

Enabling this channel will automatically set the calibration to "RPM" and the time series plot will show RPM versus Time. Although the other plot types (Spectrum, Spectrogram, 3-D Surface, Phase) are available, they are not meaningful for the tachometer channel.

A resizeable RPM utility window is also available - click the <Utilities><Tachometer RPM> menu to open this window. It shows the current RPM value.

The RPM value is also available for data logging in the list of output data items.

Refer to the hardware documentation for tachometer signal requirements.

The Tachometer data can be recorded and post processed. It is stored in a wave file as an integer value equal to the actual RPM * 100. The maximum RPM than can be detected is 83,886.


Time Series Plot Options

The Time Series plot options dialog box can be activated by selecting the <Options><Plot Options><Time Series> menu or by clicking on the options dialog icon button in the plot toolbar .

Plot Type: If Amplitude (linear) is selected, the display is similar to an oscilloscope (the data is scaled linearly around the centerline). When the Energy (logarithmic) option is selected, the data is scaled in Decibels using the current calibration settings.

Plot Top/Center/Range: The Plot Top, Plot Center and Plot Range values determine the amplitude axis scale values. When the amplitude (linear) option is selected, the Plot Top value determines the upper and lower plot limits and the Plot Range value is not used. When the Energy (logarithmic) option is selected, the Plot Top is the value at the upper edge of the plot and the lower edge of the plot is equal to the Top value minus the Range value.

Start and Stop Times: These allow you to directly specify the displayed time segment.

Colors: The color of each plot feature can be changed. The default button will restore the initial colors settings.

Show Gridlines: Show or hide the horizontal or vertical gridlines.

Show Toolbar: Show or hide the time series plot toolbar. A small + or - button below the toolbar also controls this feature.

Pull Cursor to Trace: If this option is enabled, the measurement cursor will automatically "pull" to the trace along the amplitude axis.

Display Update Interval: Controls how often the display is updated. This is useful on some laptop computers with slow display refresh rates to reduce flicker.

Copy these settings to other channels: Allows you copy the plot options to other channels you select.

See Also: Time Series Plot


Tone Burst

This option allows you to generate a tone burst. The "Burst Time" defines the length of the tone period. The "Cycle Time" specifies the repetition period. For instance, if the Burst Time is set to 1000 msec and the Cycle Time is set to 2000 msec, the generator will output 1 second of silence followed by 1 second of tone signal. This pattern will repeat until the generator is stopped.

See Also: 1kHz Tone , Multiple Tones , Generator Output Level


Transfer Function

A transfer function is a total measurement of the amplitude and phase response of a device under test

A key part of an accurate transfer function is the removal of the input test signal response from the final measurement. This is done by passing a sample of the input signal to the second channel of the analyzer and removing its response from the response of the device under test.

You should use logarithmic amplitude scaling; subtracting two logarithmic quantities equates to division of their ratio values.

Procedure:

  • Connect a noise generator to the input of the device under test.
  • Connect the output of the device under test to one input channel of the analyzer.
  • Connect same signal generator to a different input channel of the analyzer.
  • Setup a Composite Channel to produce the transfer function between the two channels
  • Run the analyzer until the average spectrum response settles to a consistent level.

Interpretation:

The spectrum display contains the amplitude response of the device and the phase display contains the phase response.


Triangular Waveform

The Triangular waveform produces a continuous train of triangular signals. The frequency of the triangular waveform can be adjusted by clicking on the "Details" button on the main screen. The Frequency setting specifies how many triangular cycles are generated each second.

See Also: Signal Generator


User Defined Waveform

The user defined waveform option allows you to use a WAV file as the signal source. The signal will be looped continuously until you press the Stop button. Simply click on the "Pick" button to choose the .WAV file. Since the signal generator loads this file into memory, you must have sufficient RAM on your computer.

SpectraPLUS-DT allows you to build your own .WAV files from an ASCII text or binary file of sample data. See the < File><Import > topic for more details.

See Also: Save Signal to .WAV file , Signal Generator


Measurement Utilities

These measurement utility windows can be resized as required by the user and their contents will update anytime a new spectrum is computed.

Peak Frequency

Peak Amplitude

Total Power

Total Harmonic Distortion (THD)

Total Harmonic Distortion + Noise (THD+N

THD+N vs Frequency

InterModulation Distortion (IMD

Signal to Noise Ratio (SNR

Signal to Noise and Distortion (SINAD)

The window will contain the channel index and name; the channel name can be modified in the Calibration Settings .

Right clicking on the utility window will allow you to copy the contents to the clipboard.


White Noise

White noise is a commonly used random noise waveform which has uniform amplitude for all frequencies. Its averaged spectrum is flat when ploted on a narrowband spectrum analyzer.

The cutoff frequency is governed by the sampling rate used by the analyzer.

See Also: Signal Generator , Pink Noise